mouse wheel scrolls random list box

VERIFIED DUPLICATE of bug 33732

Status

P3
normal
VERIFIED DUPLICATE of bug 33732
19 years ago
10 years ago

People

(Reporter: kevin.gilpin, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If I click in one of the edit boxes (e.g. Email(Assigned To) or EMail(Reporter)
and then scroll using the wheel on my mouse, a pseudo-random list box is
scrolled. I would expect there to be no scrolling behavior if an edit box has
the  focus, or perhaps for the whole page to scroll
(Assignee)

Comment 1

19 years ago
bryner@uiuc.edu, do you know this?

Comment 2

19 years ago
What build of Mozilla are you running?
(Assignee)

Comment 3

19 years ago
asadotzler@netscape.net (Asa Dotzler) taking ownership of Browser General bugs. 
 New QA Contact is jelwell@singleclick.com (Joseph Elwell).  Sorry for the spam.
Assignee: cbegle → asadotzler
QA Contact: asadotzler → jelwell
kevin.gilpin@alum.mit.edu - we need to know what build of Mozilla you are 
running, and whether you still see this problem in current builds. If we don't 
get that information, we will be unable to proceed with fixing this bug, and it 
will be marked INVALID :-)

Hope to hear from you soon,

Gerv
Reporter told me he was using M14 in private mail. I have asked him to attempt to 
reproduce this on a later build.

Gerv

Comment 6

19 years ago
I can confirm this one.

Some details about my setup:
I use a Logitech MouseMan Wheel mouse, running the MouseWare 9.0 drivers on
Windows NT 4 Workstation. Under the Mouse applet of Control Panel, I've set up
my mouse wheel to control vertical scrolling. Scroll size is set to 1 line, and
the MS Office Compatible Scroll checkbox is unchecked.

When using the mouse wheel on the Bugzilla query page, I get the same behaviour
as the reporter.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

19 years ago
I tried to reproduce this and could not. I also wrote a lovely 10 minute 
explanation that mozilla wiped out when I did something unrelated. So no 
niceties.

Basically, I loaded the URL, clicked on the text section "Email:" and tried 
using my mouse wheel.

Results: whole page scrolled.

kevin.gilpin@alum.mit.edu,run2000@geocities.com: I need a better step by step 
explanation of what you did to reproduce. Just clicking on a text field and 
scrolling doesn't produce your bug. Download 
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32.zip and try 
again. If it's still broken re-open this bug. Otherwise, please mark this bug as 
verified.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 8

19 years ago
Actually, what you just described is a bug, that I also just noticed.  If you
click inside a list box and then scroll with the mousewheel, the box *should*
scroll (not the page).  It seems that the box is not taking focus for some
reason-- I'm investigating.
(Assignee)

Comment 9

19 years ago
This needs to be reopened.  The page should not scroll when the list box has
focus.  bryner is this yours or editor's
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Asa-  I think you are morphing this bug into something else.  The original bug 
was that if the focus was in a text field, and you scrolled with the mousewheel, 
a listbox would scroll.  I'm unable to reproduce this at all.

If you're seeing some other problems where the page scrolls when a listbox is 
focused (which it shouldn't), please open another bug on it.  Thanks.
(Assignee)

Comment 11

19 years ago
oops, sorry.  Resolving again.  Trying to do too many things at once.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
(Assignee)

Comment 12

19 years ago
oops, sorry.  Resolving again.  Trying to do too many things at once.
(Assignee)

Comment 13

19 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr
verified
Status: RESOLVED → VERIFIED
Reopening so I can mark this a dup.
Status: VERIFIED → REOPENED
This is really 33732, I'm pretty sure.  I know what causes that bug, but
unfortunately I haven't found a good solution that doesn't break other things in
the process.  This problem should go away when gfx scrollbars are implemented on
listboxes (see bug 18895).


*** This bug has been marked as a duplicate of 33732 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 17

18 years ago
bryner, sure enough to verify?
Keywords: verifyme
Sure, I will verify.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.