Keyboard shortcuts don't work when keyboard layout is other than English

RESOLVED DUPLICATE of bug 246491

Status

()

--
major
RESOLVED DUPLICATE of bug 246491
13 years ago
11 years ago

People

(Reporter: alex, Unassigned)

Tracking

1.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051106 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051106 Firefox/1.0.7

When the keyboard layout is other then English (say Russian) none of shortcuts works. But when I select Engish layout (qwerty) all of them works fine.
For example, keyboard copy and paste does not work with Russian keyboard layout.
Nevertheless on Windows XP this shortcuts works with any layout.

Reproducible: Always

Steps to Reproduce:
1. Choose any non-qwerty keyboard layout
2. Try some shortcuts. Copy-Paste for example.

Actual Results:  
Nothing happens. shortcuts does not work.

Expected Results:  
Obviously I expect to perform the shortcut's action.

I did not try to reproduse this bug on layouts with contains both latin characters and non-latin such as umlauts in german. I did not try to reproduce this bug on other Desktop environments other then GNOME. But here this bug sits for long time (FF 1.0.5, 1.0.6, 1.0.7 and GNOME 2.6, 2.8, 2.10 and 2.12.1).
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch

Comment 1

13 years ago
Could you download Firefox 1.5 and see if you're still seeing this? http://www.mozilla.org/projects/firefox/
Summary: Keyboard shortcuts doesn't work while keybord layuot is other then English → Keyboard shortcuts don't work when keyboard layout is other than English
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Could you download Firefox 1.5 and see if you're still seeing this?
> http://www.mozilla.org/projects/firefox/
> 

Yes, I'm still seeing this in FF 1.5 RC2.

Comment 3

13 years ago
dup of bug #246491

*** This bug has been marked as a duplicate of 246491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.