licensing on firefox icon is too restrictive

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: mike, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)

linux distributions are only able to bundle firefox with a modified icon. 

Reproducible: Always



Expected Results:  
I would expect that firefox be included with the good looking firefox icons in linux distributions.
That's not at all true, Novell and Red Hat both ship distributions with official branding.  There are requirements for using the logo/name, as described here: http://www.mozilla.org/foundation/licensing.html which are required under US trademark law.  If a Linux distributor is claiming otherwise, they should be referred to the link provided.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
According to the link, you have to distribute unaltered binaries.  Of course every distribution is going to compile firefox themselves and alter firefox to fit the layout of their own directory structure.  Debian has no interest in branding firefox and distributes firefox with a very ugly icon. 

Every distribution changes the icon. 

I'll make sure to get in contact with the packagers, but if what you say is correct then the problem is the distribution feel that the license is too restrictive.  
Debian's issues with our license are well-known and probably easily searched for with Google on debian's licensing list.  Altered binaries are ok provided that the patches to be applied are approved by the appropriate people, but this impairs derivative versions of debian linux from simply reusing the mark.

Either we do this, or the trademark is worthless.  Note that Debian has a similar policy regarding the use of their marks, which are equally trademarks and subject to the same degree of enforcement as Firefox.
You need to log in before you can comment on or make changes to this bug.