Select search engines directly via keyboard (first/last search engine via Ctrl+Home/Ctrl+End, Ctrl+<n> for n-th engine)

RESOLVED DUPLICATE of bug 312849

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 312849
13 years ago
11 years ago

People

(Reporter: Martin F., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

Holding down [Ctrl] when pressing [Home] or [End] should select the first/last search engine.

Reproducible: Always

Steps to Reproduce:
1. Hold down [Ctrl] and press [Home] or [End] when the cursor is in the search toolbar.
Actual Results:  
Cursor jumps to the start/end of the text, as with [Ctrl] not being held down.

Expected Results:  
The first/last search engine should be selected.
(Reporter)

Comment 1

13 years ago
Selecting search engines directly by pressing Ctrl and a number when the cursor is in the search box would also be useful. Ctrl+1 for the first engine and so on.
Summary: Select first/last search engine via Ctrl+Home/Ctrl+End → Select search engines directly via keyboard (first/last search engine via Ctrl+Home/Ctrl+End, Ctrl+<n> for n-th engine)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382436

Updated

11 years ago
Duplicate of bug: 312849
You need to log in before you can comment on or make changes to this bug.