Certain java applets casue abrupt crash onload.

VERIFIED DUPLICATE of bug 177268

Status

Core Graveyard
Java: Live Connect
--
critical
VERIFIED DUPLICATE of bug 177268
13 years ago
8 years ago

People

(Reporter: Ken Johanson, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051112 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051112 Firefox/1.6a1

Sun Java 1.4.09 + Firefox 1.5 beta installed on Linux (Fedora 4 / Kernel 2.6.13-1.1532_FC4), with certain applets (probably JSObject / scriptable ones) (sample listed in steps to reproduce) cause abrupt browser crash. Firefox 1.07 on same platform works fine.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.java.com/en/download/installed.jsp
2. Click on yellow 'verifiy installation' button.




Sorry, I didnt see a 'plugins' category to file this under; files under 'General'.

This has courred for at least one or two months of 1.5 branches that Ive tested.

Java plugin installed using cp [java.home]/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so [firefox.home]/plugins, also tried /ns610/libjavaplugin_oji.so.
(Reporter)

Comment 1

13 years ago
Arg. I see there is a Core->LiveConnect category; attempting to move..
Component: General → Java: Live Connect
Product: Firefox → Core
Version: unspecified → 1.0 Branch
(Reporter)

Comment 2

13 years ago
Arg. I see there is a Core->LiveConnect category; attempting to move..
Version: 1.0 Branch → Trunk

Comment 3

13 years ago
worksforme with Sun's JRE 1.5 and SeaMonkey current CVS.

did you symlink the plugin rather than copying it?
http://plugindoc.mozdev.org/linux.html#Java

Does it print a message when it crashes?

Updated

13 years ago
Severity: major → critical
Keywords: crash
(Reporter)

Comment 4

13 years ago
Confirm, symlinking the .so resolves the crash... Thank you!!

However, the fact that firefox 1.0.x does not crash with a copied (not symlinked) .so does seem to indicate a new backward-compat problem...

Alternatively, it may be acceptable if the ditros had a README and/or script in the plugins diretory that recommends symlink vs. copy, or if a app-message did (before the crash :-).

No message was printed before the crash. I would use 5.0 but prefer to develop using 1.4 t test for backwards compatibility; I did not check with 5.0.
(Reporter)

Comment 5

13 years ago
I just investigated how our bretheren handle the Java plugin for Konqueror/KHTML...

They have a 'java' settings panel, and in there one can specify the path to the java executable. Thereafter, their system apparently locates the plugin and applets run with full scriptability, etc. I did not test to see if java worked before defining the fully qual'd path, but theoretically if the java executable is on the PATH it could resolve as well...

This seems like the more modern approach to finding a JVM-plugin, vs. having to copy/symlink shared libs, though (from what little I know about moz core), Firefox would need code to specifically search for java plugin (which it does not currently, only Seamonkey does?) Does anyone know of a bug/rfe that I could watch relating to auto java plugin detection in FF?

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 177268 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
The Java plugin itself calls exit() if it can't find the JVM (and it can't find it if you copy it). Ask Sun if you have problems with that
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.