"Illegal Operation in Plug-in" closing window with Windows Media Player running (followed by a hang of sorts)

RESOLVED WORKSFORME

Status

Plugins Graveyard
Windows Media Player (Microsoft)
--
critical
RESOLVED WORKSFORME
13 years ago
2 years ago

People

(Reporter: Peter Flynn (Oracle), Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

Occurs in FF 1.5 RC 2:

Reproducible: Always

Steps to Reproduce:
1. Go to cnn.com and click any of the links to open a video clip (in the green box)
2. Close the popup window while the video is playing
Actual Results:  
Dialog box appears, titled "Illegal Operation in Plug-in":
"Windows Media Player Plug-in Dynamic Link Library

The plug-in performed an illegal operation. You are strongly advised to restart Firefox."

I click Ok, and the popup window reappears for a brief flash. Thereafter, FF acts oddly:
- mouseover highlights do not appear on menu items
- clicking menu items does nothing
- clicking links does nothing (other than move the focus)
- if I close all FF windows, the process remains running; I have to kill it

Expected Results:  
None of the above

Using WMP 9. The npdsplay.dll version is 3.0.2.628 (unsure if that matters).

The only extension installed is Mouse Gestures 1.0.2.

Are there any logs or anything where I can dig up more details on the 'illegal operation' in WMP?
(Reporter)

Updated

13 years ago
Version: Trunk → 1.8 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051112 Firefox/1.5 ID:2005111223

Works for me.
the "illegal operation" means that the plugin crashed
(Reporter)

Comment 3

13 years ago
It now WFM on 1.5 final. Possibly fixed by bug 316025.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Windows Media Player (Microsoft)
Product: Core → Plugins
QA Contact: plugins → microsoft-wmp
Version: 1.8 Branch → unspecified
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.