Closed Bug 316249 Opened 17 years ago Closed 15 years ago

Arabic digraph glyphs used in block elements but not in inline elements

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: tonymec, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051112 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051112 Firefox/1.5

When Arabic font and RTL orientation are set at block level (e.g. by <TD class="arabic"> in the page at the above URL), digraph glyphs (Presentation Form A) are used when appropriate. However, when set in inline elements (e.g., by <span class="arabic">) they are not used; in that case only contextual forms of individual characters (Presentation Form B) are used.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://users.skynet.be/antoine.mechelynck/other/prenoms.alif.htm
2. Scroll to lines for akhyâr, alâ, alh.ân, amjâd.
3. Notice that the glyphs "yeh-reh final", "laam-yeh isolated", "laam-alif maksura isolated", "laam-hah initial", "meem-jeem initial" are not used in the left-hand column, where Arabic words are embedded in French text; the corresponding multi-letter glyphs (and any other) are used when appropriate in the second table column from left, where Arabic text is set at block level.

Actual Results:  
See step 3 above.

Expected Results:  
Digraph glyphs should have been used in the left-hand column just like they were in the second column from left.

Additional notes:

1. I can't test for this bug except on PC/XP. Please set it to All/All if appropriate.

2. Workaround: Specify Presentation A glyphs explicitly; however, neighbouring characters are in this case not shown in the appropriate initial, medial or final shape, so Presentation B glyphs must also be specified explicitly left and right until the nearest word break or non-joining letter. This procedure is explicitly deprecated in the Unicode normative documents.

3. If you don't have the Traditional Arabic font installed, you can either download the page and edit the <style> in the HEAD part of the HTML, or set some appropriate default Serif font. Check in the 2nd column from left if your Arabic font possesses the digraphs in question.
The "strange" character at step 2 in comment 0 is an a-circumflex; it will display correctly if you set "character encoding" to UTF-8.
This is a known bug with align="justify". See bug 157967 and bug 297074, and various dupes.
Fixed in trunk builds by Cairo
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.