Automatic image resizing will size an image to 0px

RESOLVED DUPLICATE of bug 351969

Status

()

RESOLVED DUPLICATE of bug 351969
14 years ago
6 months ago

People

(Reporter: kyle, Assigned: jdunn)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051025 Firefox/1.5

If an image is say 1px by 3000px (such as a repeat-x background image) and are viewed with say "view background image" then they are scaled down (if the feature is turned on) so small that they can't be zoomed in. It is as if there is no image at all.

Reproducible: Always
That does seem a little too much: nsImageDocument.cpp's GetRatio() probably ought to return a ratio that won't make either dimension zero.
Assignee: nobody → jdunn
Component: General → Layout: Images
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout.images
Hardware: PC → All
Summary: 1px by really tall height images are scaled down and can't be zoomed → Automatic image resizing will size an image to 0px
Version: unspecified → Trunk
Duping forward, since CTho was crazy enough to assign his bug to himself.

*** This bug has been marked as a duplicate of 351969 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

6 months ago
Product: Core → Core Graveyard

Updated

6 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.