Closed Bug 31641 Opened 20 years ago Closed 19 years ago

<mtable> in display mode not centered

Categories

(Core :: MathML, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla0.9.2

People

(Reporter: gartside, Assigned: rbs)

References

()

Details

An <mtable> inside <math mode="display"> will not be centered.

If the <mtable> is wrapped in <mrow> ... </mrow> then it is centered.

See the example page.
Accepting bug
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv
Have fix - setting target milestone to m0.9.2.
Got an updated URL?
OS: Linux → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9.2
New URL for example page:

http://pear.math.pitt.edu/mathzilla/mtableBug.xml

(Note also missing column in the matrix wrapped in an <mrow>)
bstell, got another iteration? The patch is still not addressing my points.
err... wrong bug - my comments were intended for bug 16688.

Landed what it will take to center the table although the surrounding
parentheses won't stretch (this a general problem) when <math> is the
direct XML parent of stretchy elements.

Resolving as FIXED since it resolves the centering problem.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
I confirm that centering is fixed. Thanks, Roger.

Should there be a new bug for stretchy children of <math> ? 
Yes. Although that will be a tough one because <math> does line
breaking/wrapping :-)
VERIFIED per comments from reporter
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.