sonyericsson.com - invalid use of keyCode (unable to input data into the textbox)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
4 years ago

People

(Reporter: beehuatling, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051113 Camino/1.0b1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051113 Camino/1.0b1+

When the website ask for the current software version, i am unable to input any text. 

Reproducible: Always

Steps to Reproduce:
1.go to http://www.sonyericsson.com/spg.jsp?cc=sg&lc=en&ver=4000&template=ps1_1_3_2&zone=ps&lm=ps1_1&pid=10183
2.click on " getting started now" for the next page to be loaded
3.click on " next" to select the manual verification mode and wait for the next page to be loaded
4.User is suppose to enter the software version in the text box "CDA" but unable to do so.
Something's amiss with the JavaScript; disabling JavaScript allows the text entry (but busts other things, of course).  Fx exhibits the same problems, -> Core
Assignee: mikepinkerton → general
Component: HTML Form Controls → DOM
Product: Camino → Core
QA Contact: ian
Version: unspecified → 1.8 Branch
Fails on Windows as well using: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
Created attachment 203037 [details]
Testcase

This testcase shows the function which causes the problem. I don't know much about JS so I apologize if this can be reduced further.
Created attachment 203042 [details]
Better Testcase
Attachment #203037 - Attachment is obsolete: true
See http://developer.mozilla.org/en/docs/DOM:event.keyCode and http://www.mozilla.org/editor/key-event-spec.html . The keyCode property of a keypress event is only set for input that doesn't map to a character.
Assignee: general → english-other
Component: DOM → English Other
Product: Core → Tech Evangelism
QA Contact: ian → english-other
Summary: unable to input data into the text box → sonyericsson.com - invalid use of keyCode (unable to input data into the textbox)
Version: 1.8 Branch → unspecified

Comment 6

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.