If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

checksetup.pl fails under MySQL5.0

RESOLVED DUPLICATE of bug 314080

Status

()

Bugzilla
Installation & Upgrading
--
major
RESOLVED DUPLICATE of bug 314080
12 years ago
12 years ago

People

(Reporter: Terry Weissman, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
The symantics of joining tables has changed subtly under MySQL5.  They don't happen in left-to-right order; "OUTER JOIN" or "," has lower priority than LEFT JOIN.  You can add parenthesis to influence this ordering.

For more details, see http://dev.mysql.com/doc/refman/5.0/en/join.html .

I will attach a very simple patch that fixes the instance of this that I have seen so far.  This patch seems to work fine under MySQL4.0 as well, so at least that isn't a problem.
(Reporter)

Comment 1

12 years ago
Created attachment 203008 [details] [diff] [review]
Proposed patch

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 314080 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.