Last Comment Bug 316447 - inserting an horizontal rule <HR> sets size="2" width="100%"
: inserting an horizontal rule <HR> sets size="2" width="100%"
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla14
Assigned To: :Aryeh Gregor (away until August 15)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-14 14:55 PST by Alfonso Martinez
Modified: 2012-04-06 11:48 PDT (History)
3 users (show)
ayg: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.21 KB, patch)
2012-04-04 03:48 PDT, :Aryeh Gregor (away until August 15)
ehsan: review+
Details | Diff | Review

Description Alfonso Martinez 2005-11-14 14:55:45 PST
Using the Insert Horizontal rule command in Thunderbird or in a Midas editor  inserts <hr size="2" width="100%"> instead of just inserting <hr>
Comment 1 :Aryeh Gregor (away until August 15) 2012-04-04 03:30:44 PDT
Test:

data:text/html,<!doctype html>
<div contenteditable>foo</div>
<script>
getSelection().selectAllChildren(document.body.firstChild);
document.execCommand("insertHorizontalRule");
document.body.textContent =
document.body.firstChild.innerHTML;
</script>

Result is

  <hr style="width: 100%; height: 2px;">

Should be

  <hr>

Confirmed in a mozilla-central build.
Comment 2 :Aryeh Gregor (away until August 15) 2012-04-04 03:48:26 PDT
Created attachment 612142 [details] [diff] [review]
Patch v1

AFAICT, the attributes were useless anyway, because that's the default height/width for an <hr>.
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-04 09:36:34 PDT
Comment on attachment 612142 [details] [diff] [review]
Patch v1

Review of attachment 612142 [details] [diff] [review]:
-----------------------------------------------------------------

I think the original plan was to make these values customizable via prefs, but I don't think we want to do that!
Comment 4 Mozilla RelEng Bot 2012-04-05 07:24:40 PDT
Autoland Patchset:
	Patches: 612142
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=0c0a0a7cd903
Try run started, revision 0c0a0a7cd903. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=0c0a0a7cd903
Comment 5 Mozilla RelEng Bot 2012-04-05 12:06:16 PDT
Try run for 0c0a0a7cd903 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0c0a0a7cd903
Results (out of 219 total builds):
    success: 181
    warnings: 35
    other: 3
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-0c0a0a7cd903
Comment 6 :Aryeh Gregor (away until August 15) 2012-04-06 00:17:00 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ad9d219c1855
Comment 7 Matt Brubeck (:mbrubeck) 2012-04-06 11:48:50 PDT
https://hg.mozilla.org/mozilla-central/rev/ad9d219c1855

Note You need to log in before you can comment on or make changes to this bug.