Non-standard upper-case chars are input as lower case

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Laurent, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 5-15-2010])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

My keyboard is a French Azerty keyboard. I use a modified keyboard driver [1] so that I can input special characters such as: É Ç Æ Œ. The driver was created using a standard Microsoft procedure available on MSDN and is widely used. It works in *all* Windows software, as it functions at the OS level, not the program level.

It works on Firefox 1.0.7.

On Firefox 1.5 RC2, the characters are all lower case, e.g. é ç œ æ. However, using the standard combining grave accent (AltGr+7, standard on all Azerty keyboards) or the combining acute accent (AltGr+1, specific to this driver) I can get capital letters.

Please note: this is NOT an issue on the keyboard driver. The problem ONLY occurs in recent versions of Firefox. It is a REGRESSION from Firefox 1.0.

[1] http://home.tiscali-business.be/~fbou2235/kbdfrac.htm


Reproducible: Always

Steps to Reproduce:
See above.

Comment 1

11 years ago
discussion in bug 327342 (which is for Thunderbird)

Updated

11 years ago
Duplicate of this bug: 374311
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 5-15-2010]
Version: unspecified → 1.5.0.x Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 5

8 years ago
Sorry to do it a bit late, problem is solved now in the more recent versions of FireFox (3.5 or more). Now my customized keyborad driver works fine.

Updated

8 years ago
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.