Keyboard Shortcuts ignored until menu is selected (new shortcut for minimizeWindow/Cmd+M works only when Window menu is opened. if Window menu is closed, Cmd+M still invokes minimizeWindow))

VERIFIED DUPLICATE of bug 429824

Status

defect
--
minor
VERIFIED DUPLICATE of bug 429824
14 years ago
5 years ago

People

(Reporter: nmagedman, Unassigned)

Tracking

Trunk
PowerPC
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

I have changed my keybindings (properly, "Keyboard Shortcuts") for Minimize and Zoom via the "Keyboard & Mouse" System Preferences.  Initially, Firefox ignores both of these bindings.  However, once I click on the "Window" menu, Firefox incorporates the bindings and they work from then on.

FYI: The default keybinding for Minimize is Cmd-M.  Zoom has no default keybinding.  I have changed these to Cmd-Opt-M and Cmd-M, respectively.  Call me silly.

Possibly related bugs:
* Bug #316076 ("complete menu implementation Cocoa widgets")
* Bug #282097 ("Mozilla, Firefox and Thunderbird fail to respect DefaultKeyBinding.dict") but this is not regarding that file (at least not directly), is not associated with HTML form widgets, and eventually resolves itself (once the menu is selected).


Reproducible: Always

Steps to Reproduce:
1) Add Keyboard Shortcuts for Minimize and Zoom:
	Launch System Preferences.
	Click on Keyboard & Mouse.
	Click on the Keyboard Shortcuts tab.
	Click on on "+" button.
	Choose Application "All Applications".
	For Menu Title: type Minimize.
	For Keyboard Shortcut: press Cmd-Opt-M.
	Click Add.
	Repeat for "Zoom" and Cmd-M.
	Quit System Preferences.  (not sure how else to trigger a save.  It presumably does not require a save, but I've noticed that if you don't quit, there can be some lag time before kicking in)

2) Confirm changes took effect:
	Launch any Apple-produced application.  Network Utility is nice.
	Press Cmd-M.  Confirm window maximizes ("zooms").
	Press Cmd-Opt-M.  Confirm window minimizes.
	Quit.

3) Confirm change doesn't work in Firefox:
	Launch Firefox.
	Press Cmd-M.  Window ought to maximize (zoom), but it minimizes instead.
	Restore window by clicking its icon in the dock.
	Repeat as necessary, just like shampoo.
	Also try out Cmd-Opt-M.  Window ought to minimize, but instead there is no reaction.

4) Click on "Window" menu.
5) Remove focus from Window menu by clicking on Firefox window.
6) Confirm shortcuts now work:
	Press Cmd-M.  Window zooms.
	Press Cmd-Opt-M.  Window minimizes.


Actual Results:  
System-wide custom Keyboard Shortcuts (e.g. Cmd-M = Maximize) are ignored until Window menu selected.

Expected Results:  
Should work as configured even before Window menu is selected.

Bug also manifests in nightly build Deer Park Alpha 2 "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051114 Firefox/1.6a1".

Bug does NOT manifest in Camino "Version 2005042806 (0.8.4)"
Summary: Custom Keyboard Shortcuts for menu items are ignored until menu is selected. → Keyboard Shortcuts ignored until menu is selected.
Assignee: nobody → joshmoz
Component: Keyboard Navigation → Widget: Mac
Product: Firefox → Core
QA Contact: keyboard.navigation → mac
Version: unspecified → Trunk
I have a similar problem.  I installed the Sage extension - to toggle Sage, the keyboard shortcut is Option-S.  Firefox completely ignores my repeated input until I select the Tools menu, where Sage puts itself, and then try again with Option-S.
Similarly, if I do Apple-comma, to bring up the Preferences dialog, Firefox will ignore the shortcut until I select the Firefox menu and then do Apple-comma again.
Duplicate of this bug: 256677
See also bug 397348 for a Cocoa problem with system keyboard shortcuts.
This appears to be what I am currently experiencing with Firefox 3.0.2 running on Mac OS 10.4.11.
Though it never claimed to fix this, FF 3.0.3 behaves the same as far as this issue goes.
Can confirm public.bob's comment, FF 3.0.3 has same behavior.

I am constantly switching between OS X and other platforms, my cut and paste muscle memory really would like to be able to use the remapped shortcuts I have defined.

Until this is fixed I have unfortunately been forced to use Safari.
Josh, is this bug somehow related or a dupe of bug 429824? Bug 429824 is a regression, so I'm not sure.
Assignee: joshmoz → nobody
Firefox 3.5 on OS X 10.5, I STILL cant use my own keyboard shortcuts.
I can change them in System Preferences, and they show up in Firefox's menubar, but nothing happens when I type them.
Will this seriously never be fixed?
Product: Core → Core Graveyard
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
This bug is never dup of  bug 429824. This bug can not be dup of  bug 429824.
This bug is Cmd-M version of Bug 938303(and bug 457973, bug 515395, bug 624881, bug 646362) which were wrongly closed as dup of bug 429824.

When default shortcut of a menuiem(Window Minimize in this bug) is defined as key bindins in Firefox, <key key/modifies == TheDefaultShortcutkey(Cmd+M in this bug) command="command_name">,
shortcutkey assingment for the menuitem to other one(Cmd+Option+M in this bug) works if menu is opened, but , if menu is closed, command_name defined for original shortcut in <key> is still  invoked by pressing original shortcut defined by <key>.

Reopening, with setting dependency to Bug 938303 for ease of analysis and tracking.

Window Zoom case is different, because no "default key binding" is defined and "Full Screen Window" is relevant.
See bug 827652, which was closed as dup of bug 429824, for Window Zoom case.
Status: RESOLVED → REOPENED
Depends on: 938303
Ever confirmed: true
Resolution: DUPLICATE → ---
Definition of minimizeWindow and zoomWindow
> Where string of "minimizeWindow" is used.
>   http://mxr.mozilla.org/mozilla-central/search?string=minimizeWindow
> Key binding for minimizeWindow
>   http://mxr.mozilla.org/mozilla-central/source/toolkit/content/macWindowMenu.inc#11
> key value/label value for minimizeWindow, label value for zoomWindow
>   http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/baseMenuOverlay.dtd#5
> menuitem for minimizeWindow, zoomWindow
>  http://mxr.mozilla.org/mozilla-central/source/toolkit/content/macWindowMenu.inc#33

A. Same solution as bug 938303 is possible in minimizeWindow/Cmd+M case : remove command from <key>.
B. Solution like bug 938303 is not applicable to zoomWindow case, because <key> is not defined for zoomWindow.
    Because <key> is not defined for zoomWindow, it may be different problem from minimizeWindow/Cmd+M case,
    but it may be alredy improved in recent Firefox.
    Further, problem like bug 827652, which was sadly closed as dup of bug 429824, should be resolved.
Summary: Keyboard Shortcuts ignored until menu is selected. → Keyboard Shortcuts ignored until menu is selected (new shortcut for minimizeWindow/Cmd+M works only when Window menu is opened. if Window menu is closed, Cmd+M still invokes minimizeWindow))
In all of Command-Q, Command-M, Command-J case, definition style  is same.
   <key id="key_Keyname" key="key_top_value"  modifies="accel" command="ID_of_command_for_menu">
   <menuitem id="ID_of_menu" key="key_Keyname" command="ID_of_command_for_menu">
Difference is:
   key binding      Major menu     Sub menu       <key>
   Command-Q    Firefox             Quit Firefox     Hotkey: Q,accel, id = key_quitApplication,   command = cmd_quitApplication
   Command-M   Window            Minimize         Hotkey: M,accel, id = key_minimizeWindow, command = minimizeWindow
   Command-J    Tools                 Download       Hotkey: J,accel,  id = key_openDownloads,   command = Tools:Downloads

Phenomenon depends on Major menu? Or phenomenon depends on used oncommand script invoked via command?
Affected by shortcut of OS X or Finder?
   Command-Q        Quit the frontmost application
   Command-M        Minimize the active window to the Dock
   Command-M        Minimize window (Finder)
   Command-J          	Scroll to a selection
   Command-J          Show View Options (Finder)

In other bug reports after Firefox 3, following phenomenon is seen.
   When newly assigned keyboard shortcut is pressed, menu blinks, but menuitem is not executed.
Does this occur in recent Firefox? (Firefox 29.0.1 as of today)
No longer depends on: 938303
Status: REOPENED → RESOLVED
Closed: 9 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.