Middle button over scrollbar=>scrolls always

RESOLVED FIXED in M18

Status

()

P3
normal
RESOLVED FIXED
19 years ago
19 years ago

People

(Reporter: Sebastian, Assigned: eric)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
1) Load a page longer than window
2) Click the middle mouse button with the mouse pointer over the scrollbar
3) Scrollbar will scroll all the time wherever you move the mouse on the screen

(4) a second click will paste current clipboard in URL bar and scrolling stops,
   if you want you can restart here with 2)

expected: paste clipboard to URL bar; maybe scroll as long a one holds down the 
          button
build 03/11, Win95

Comment 1

19 years ago
Why would you expect middle click on the scrollbar to paste anything, 
especially into the URL bar, especially on Win95?
(Reporter)

Comment 2

19 years ago
Since some time, middle click pastes the clipboard in the URL bar and loads it, 
independent from the OS.
But middle mouse button clicking (*not* holding it down) should never keep the 
page scrolling, independent of whereever you move the mouse on the screen.

Comment 3

19 years ago
Changing OS to other.  When I try this on Linux using today's NS b1 build, it
seems to ignore the mouseup on the middle button,
the thumb continues tracking the cursor.  A second middle-mouseDown brings up an
alert saying "<contents of clipboard> could not be found,
please check the name and try again", where <contents of clipboard> is the
actual contents of the clipboard rather than the literal string.  After
dismissing this, the thumb continues to track the cursor until I right-mouseDown
a few times.  After that, spaces typed into mult-line text fields in forms cause
a pageDown of the enclosing web page. Selection also tends to forget mouseDown
state too.  reassigning to evaughan as p3 for m17
Assignee: trudelle → evaughan
OS: Windows 95 → other
Target Milestone: M17

Comment 4

19 years ago
Mass moving M17 bugs to M18
Target Milestone: M17 → M18

Comment 5

19 years ago
I don't believe a middle mouse click on the scrollbar should do anything other
than affect the scrollbar. It is unexpected behavious when a click on a
scrollbar - any click - pastes something - anywhere. 

The same behaviour as observed in NC4.7 is desireable:
If you then middle-click the scrollbar OR scrollbar slider the slider will
"center" around the position you clicked on.

If the middle-mouse is then kept in, you see it has performed a grab on the
scrollbar slider and for as long as the middle-button is kept pressed, it will
slide the page according to mouse movements. The grab is first lost when button
raises again. 

A scrollbar is clicked on all the time with the intent to menuvre on the current
page. Any "paste to url" feature is bound to trigger a lot by accident if any
clipboard features is "tied up" to scrollbar. The entire scrollbar area should
be insensitive to clipboard actions, and any mouseclick or scrolls performed on
a scrollbar should *only* affect scrollbar widget behaviour - in other words
deal with maneuvreing on page is performed. There will be tears before bedtime
if types of scrollbar clicks take you away from the page you're currently
browsing. Unexpected behaviour from a scrollbar.

Comment 6

19 years ago
Gotta stress one point here - this is vital:
When i middle-click the scrollbar once (to scroll, expecting the scrollbar
slider to center around that position) - i *also* expect this to happen the next
time i middle-click somewhere else on the scrollbar. The same behaviour should
repeat each time i middle-click.

It shouldn't center the first time, and do something entirely different the next
time. Scrollbars responce to mouseclicks need to be consistant!
And the "paste something to URL field" should *only* happen if the cursor is
actually placed OVER the URL field. This would indicate a deliberate action from
the user.
Else you wind up pasting something in URL field as soon as you slip and miss a
link you intended to click on, and zooom - the browser is trying to load some
other page, which might be valid, not valid, or simply happen to be valid but is
one you never wished to go to.

As this works now (now and then) it isn't even certain an URL was on clipboard
at all, and all kind of gobbledigook gets pasted into URL field when you miss a
link you intended to open in a new window. (Which is what a middle-click on a
link does and should do.)

This error has happened to me several times already: One word i happened to have
on clipboard accidentally got pasted into URL field, when i simply had missed a
link.
Result is that browser tries to "run off" to an URL that don't exists: If
"urghhh-bummer" was on the clipboard, it will auto-fill in
"http://www.urghhh-bummer.com" for instance, and then tell it couldn't connect.
(Assignee)

Updated

19 years ago
Whiteboard: fixed will checkin soon
(Assignee)

Comment 7

19 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: fixed will checkin soon
You need to log in before you can comment on or make changes to this bug.