Closed Bug 316500 Opened 16 years ago Closed 11 years ago

Deleting Junk Mail opens all threaded messages

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozillabugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla Thunderbird version 1.5 (20051025)

When I select "Delete Mail Marked as Junk in Folder" it does move the messages to the Trash, but it also opens up all the threaded messages in the folder, so I have to hit '\' to close all the threaded messages.

Reproducible: Always

Steps to Reproduce:
1. View->Threads->All (or hit '\' to close all threads.
2. Tools->"Delete Mail Marked as Junk in Folder"

Actual Results:  
After performing steps 1 and 2, all the threaded messages open up in the current folder.

Expected Results:  
It should not have opened up all the threaded messages in the current folder.
QA Contact: front-end
Unable to reproduce described behavior in the trunk. Works for me. Please reconfirm if you still see this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
This is still valid on trunk.
http://lxr.mozilla.org/seamonkey/source/mail/base/content/mailCommands.js#762

I guess we could do a collapseAllThreads at the end there. Keeping all threads as they were might be trickier...
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Assignee: mscott → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Severity: normal → minor
OS: Windows XP → All
Hardware: PC → All
Blocks: junktracker
WFM - i cannot reproduce this using current thunderbird trunk build. 
Need new bug if there is a SM issue?
Status: NEW → RESOLVED
Closed: 14 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.