Closed Bug 316508 Opened 16 years ago Closed 16 years ago

Scrollbars are rendered over DIV with absolute position

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: mjuhos, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Scrollbars are rendered over DIV with absolute position, but if is set position to value "fixed", it works fine.

Reproducible: Always

Steps to Reproduce:
Try test case:

<html>
  <style>
    #long {
       width:100px;
       overflow: scroll;
     }
    #over {
       position:absolute;
       left:50px;
       background-color:red;
       width:200px;
       height:200px;
    }
    </style>
    <body>
       <div id="over">Over</div>
       <div id="long">Loooooooooooooooooooong text<br>Loooooooooooooooooooong<br> text Loooooooooooooooooooong text</div>
    </body>
</html>
Actual Results:  
Scrolbars is over DIV element which has set position as "absolute" (in testcase has id "over")

Expected Results:  
Scrolbars will be under DIV element which has set position as "absolute".

Same problem exist in Firefox 1.5. beta 2 too.
Build Identifier:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Attached file Test case

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.