it's no longer possible to redefine system scrollbars using css (-moz-binding)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
8 years ago

People

(Reporter: rvj, Assigned: jag+mozilla)

Tracking

({regression})

1.7 Branch
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915



prior to 1.7 it was possible to refine the default system scrollbar using a selector such as

scrollbar
  { 
 -moz-binding: url("file:///E:/viewport.xml#newscrollbar");
  }

where the new scrollbar is defined in an xbl binding .  This css reference in the binding would be specified via the usechromesheets attribute.

<binding id="viewport"  xbl:inherits="src"  >
<content>
<xul:iframe xbl:inherits="src" flex="1" usechromesheets="file:///E:/css.css" />
</content>
</binding>

This would allow the iframe to inherit a new scrollbar binding such as

 <binding id="newscrollbar">
 <content >
  <xul:box flex="1" style="width:40px;background:lime" /> 
  </content>
  </binding>

 Since 1.7 this no longer works . in otherwords the default system scrollbars are not overriden.

I am not sure if usechromesheet is the official attribute for this purpose - but at least it worked upto 1.6.

Should I now be specifying the scrollbar stylesheet using some alternative attribute?









Reproducible: Always

Steps to Reproduce:
1. create an XBL element with an iframe pointing to the new scrollbar stylesheet
2. create a XBL binding for the new scrollbar
3. create  css selectors for both bindings 

Actual Results:  
the iframe show the system (default skin)  scrollbar binding

Expected Results:  
the iframe will display the new scrollbar binding



Given that the skin mechanism is not exactly lightweight, a simple means of redefining system scrollbars is necessary.

If usechromesheets is no longer to function the way it did - what should we use?
Keywords: regression
Summary: regression ? it seems that it no longer possible to redefine system scrollbars using css → it's no longer possible to redefine system scrollbars using css (-moz-binding)
MozillaAS v1.7.x is not supported anymore.

Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → 1.7 Branch
No reply to comment #1 => INCOMPLETE.

Feel free to REOPEN with a comment supplying the requested information about a current build (as of this writing, SeaMonkey 2.0.11 or later).

Also, can you resolve your problem by means of the CSS "overflow" property? See also http://kb.mozillazine.org/UserChrome.css
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.