Right-click spelling correction does not show up on undo stack

RESOLVED DUPLICATE of bug 312778

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 312778
12 years ago
12 years ago

People

(Reporter: Marc Sherman, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: version 1.5 (20051025)

Correcting a spelling error using the right click menu (spell as you type) does not show up in the undo stack.  This leads to some interesting effects.



Reproducible: Always

Steps to Reproduce:
1. Open a new message compose window, click in the message text area
2. Type the following key presses:
good[space][backspace][space]badd[space]
3. "badd" will be underlined as a spelling error.  Right click, correct it to bad.  
4. Select Edit|Undo.

Actual Results:  
"good"

The entire typing action following the [backspace] was undone.

Expected Results:  
"good badd"

Expected only the spelling correction to be undone.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 312778 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.