If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

firefox should be startable from a shell (command line)

RESOLVED WONTFIX

Status

()

Firefox
Installer
--
enhancement
RESOLVED WONTFIX
12 years ago
10 months ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

The installer installs firefox in some system directory, but when typing "firefox" in a shell, it is not found (because not in $PATH by default). Starting firefox from a shell is useful to start the profile manager or start a second instance with a different profile (useful for testing, in particular). I can see two possibilities:

1. The installer installs the firefox script (or a symbolic link to this script) in some standard location such as /usr/local/bin, possibly asking the user for several locations.

2. Some information is given after firefox has been installed, telling the user what to do. For instance, add /Applications/Firefox.app/Contents/MacOS to his $PATH (but I don't think this is a good solution since there are other executables the user would probably not want in $PATH). Or add a symbolic link, in which case the installer should give the path to the firefox script (e.g. /Applications/Firefox.app/Contents/MacOS/firefox).

Reproducible: Always

Steps to Reproduce:

Comment 1

12 years ago
There is no installer - it's the user itself that dragged Firefox into /Applications or wherever it's installed. But ok, FF can check if such a link exists, and offer to create it. But I think it's not worth doing it.

Note that none of the applications in /Applications or /Applications/Utilities is reachable on the commandline. /usr/local/bin doesn't even exists in Mac OS X 10.2.8 (and it's not mentioned in the default path either).
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> There is no installer - it's the user itself that dragged Firefox into
> /Applications or wherever it's installed.

Hmm... I didn't remember that. There is an upgrade process, though.

> But ok, FF can check if such a link
> exists, and offer to create it. But I think it's not worth doing it.

Otherwise some documentation in the release notes.

Comment 3

12 years ago
This is definitely not an end-user feature. WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
Depends on: 1322223

Updated

10 months ago
No longer depends on: 1322223
You need to log in before you can comment on or make changes to this bug.