Windows Media Player Plugin Crashes and Black Box overlay

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: jer2eydevil88, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

When I go to visit my friends Xanga blog he has an Embedded WMP music video and the playback of this video crashes Firefox almost everytime I go to visit his page.  He constantly changes the video so its not the video file its firefox's handling of this plugin in OS 10.4.3.

To see the black box problem that occurs when I try to switch tabs view this picture
http://zigzap.com/up2/osxwmp.jpg

Reproducible: Sometimes

Steps to Reproduce:
1. visit the website http://www.xanga.com/ciachefdan
2. make sure you have the latest updates for OS X (10.4.3) and WMP 9 for OS X
3. try to let the page load in a tab while looking at other sites such as google.com or yahoo.com

Actual Results:  
The web browser will either crash entirely and dissappear or it will lock up and use 100% cpu.

Comment 1

13 years ago
I have the same.  It has bugged me for a while.  The only workaround I have found is to remove the plugin from /Library/Plug-Ins, this then means I have no WMP9 support that works on some sites.

I voted for this bug.  It needs fixing, perhaps make it a critical bug please.

Comment 2

13 years ago
Oh, I see you have 1.0.7, it is still in the latest version.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051231 Firefox/1.5
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Oh, I see you have 1.0.7, it is still in the latest version.
> 
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051231
> Firefox/1.5
> 

Yes the bug is still occuring in the latest version of Firefox 1.5 however I started this report when I was enduring it in 1.0.7

Comment 4

13 years ago
Yes I know, sorry for the confusion.  I was stating it is still a problem to others.

Comment 5

13 years ago
Microsoft no longer support WMP for Mac OS X.  However, they are now telling us to use Flip4Mac.  Only problem is, this plugin crashes the browser the same as WMP plugin.

Please update your plugin to v2.0.1. That should fix this problem. If it does, resolve this bug INVALID. It was a problem on F4M's end, which they fixed in the latest release.

Comment 7

13 years ago
Currently using v2.0.1.  Still crashes.
WFM using Quicktime 7.0.4, F4M 2.0.1, and Camino 1.0b2.

Also WFM with the same environment using Fx 1.5.

Does the "black box" issue happen with F4M as well? Or was that a WMP thing only? Also, Simon, does this happen with Fx 1.5 for you? Or only Fx 1.0.7?

Lane, does this happen for *you* with F4M 2.0.1?
(Reporter)

Comment 9

13 years ago
The browser doesn't crash any longer, I think flip4mac has fixed that for me.  The one problem with Flip4mac is that it only supports certain Windows Media Player extensions and not everything.
Unless someone from the Firefox team has a desire to support WMP for Mac (which Microsoft has no desire to support, it would seem), this bug should closed.
(Reporter)

Comment 11

13 years ago
I think the Firefox team should implement a safeguard for us mac users so our browser doesnt crash when we browse the web.  If Microsoft doesn't want us viewing media files they put out fine just let us keep browsing.
Microsoft has (basically) acknowledged that WMP/Mac is a bad product and has issues. That is why the provided F4M on their website as a download.

Talking with a Fx dev, WMP/Mac will no longer be supported since Microsoft has also chosen not to support it. Crashes which happen with unsupported plugins will not be fixed by the Firefox team, especially when a reasonable alternative exists.

Simon, I'm waiting on your response on whether you crash using Firefox 1.5 and F4M 2.0.1. If you don't crash, I'll close this bug.

Comment 13

13 years ago
Progress on the bug.

I went into system prefs, QuickTime, advanced tab, MIME settings button, and under video set WMV to play through QuickTime.

Firefox now doesn't crash (Safari did which is odd).  However, the video is not in the right place on the screen, sometimes disappears when scrolling.  Similar to bug https://bugzilla.mozilla.org/show_bug.cgi?id=323487 

I have tested it with a few WMV files locally and some on the web.

http://www.microsoft.com/windows/windowsmedia/demos/video_quality_demos.aspx

Seems no picture and the demos have multiple play, pause stop bars.

http://myspace.com/magicamy

Video on that page seems to get lost.  I have experienced this locally too.


I agree, we can stop support for WMP, but we should now support F4M as a lot of content on the web is WMV.  A workaround now would be a MIME type change to try to prevent WMV playing in WMP for Mac OS, and get them to default to F4M plugin.
Please file a new bug (or bugs) on the F4M issues. The developers intend to support F4M now instead of WMP/Mac. Closing this bug as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.