Plug-in window position is incorrectly set by the browser

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: vlad.alexander, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

The clipRect is set to (left:x, top:y, right:x, bottom:y) (note: it's the same value for top and bottom, and the same value for left and right). Also, the left, top corner of plugin position seems to be added a Bookmark bar's height. So that our plugin cannot get a correct position according to actual plugin window.

Reproducible: Always

Steps to Reproduce:
1. Install XStandard dev build for OS X from:
http://xstandard.com/misc/camino/2005-11-14/XStandard.plugin.zip
2. Go to this test case:
http://xstandard.com/misc/camino/object.asp
3. Hide the Bookmark bar or re-size the browser window. The plug-in area is incorrectly drawn.

Actual Results:  
The plug-in area is incorrectly drawn.

Expected Results:  
The plug-in area should be drawn correctly - do the test-case in Firefox to compare behavior.
This sounds like it might also be the issue in bug 315889?

Comment 2

13 years ago
Vlad: are you using any kind of accelerated surface (OpenGL or QuickTime)? This smells like bug 252515.

Despite installing the plugin, I can't get it to show up in the testcase. Console says:
2005-11-15 19:48:53.767 Camino[372] CFLog (21): Error loading /Users/smfr/Library/Internet Plug-Ins/XStandard.plugin/Contents/MacOS/XStandard:  error code 4, error number 0 (Library not loaded: @executable_path/../Frameworks/libxml.framework/Versions/2.6.19/libxml
  Referenced from: /Users/smfr/Library/Internet Plug-Ins/XStandard.plugin/Contents/MacOS/XStandard
  Reason: image not found)

Comment 3

13 years ago
We still need to investigate this.
Whiteboard: [CLOSEME - 1/29]
(Reporter)

Comment 4

13 years ago
We have a more recent build of a plug-in that you can use for testing:

http://xstandard.com/misc/dev/2005-12-22/XStandard.dmg
Mass-reassign of bugs still assigned to pinkerton to nobody; filter on "NoMoPinkBugsInCamino".
Assignee: mikepinkerton → nobody
QA Contact: plugins

Comment 6

11 years ago
Does this happen in trunk builds of Camino and Firefox?

Comment 7

11 years ago
Vlad, can you address comment 6, please?
(Reporter)

Comment 8

11 years ago
Sorry, I did not answer this sooner. Just tested with the latest nightly Camino build and our latest plug-in and the problem seems to be fixed. Thank you!

This may not be an appropriate place to ask, sorry, but can you guys to looks at another plug-in related bug on OS X that is affecting FF and Camino? It's filed under FF Bug 409226. This bug is really important to us.

Comment 9

11 years ago
WORKSFORME on trunk, then, and we probably don't care about branch at this point.

I doubt any of us in Camino can be of any more assistance than the guys who are already working on the other bug, but thanks for the heads-up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.