The Proxy setting of IE is not migrated.

RESOLVED FIXED

Status

()

Firefox
Migration
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Hiro, Assigned: Hiro)

Tracking

({regression})

unspecified
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking1.8.0.1 -
blocking1.8.0.2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.9a1) Gecko/20051115 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.9a1) Gecko/20051115 Firefox/1.6a1

In 1.8branch build, the Proxy setting of IE doesn't migrate from 2005-10-25. 
(The Proxy setting columns are all blanks.Till then, there was only a problem of bug266413.) 
And as for this problem, trunk reproduces. 

N.G:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
O.K:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051024 Firefox/1.5
N.G:
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.9a1) Gecko/20051115 Firefox/1.6a1

Windows XP Sp1

Reproducible: Always

Comment 1

12 years ago
You mean this regressed 2005-10-25?

If not, then this is a dupe of bug 297288
(Assignee)

Comment 2

12 years ago
(In reply to comment #1)
> You mean this regressed 2005-10-25?
> 
> If not, then this is a dupe of bug 297288

Yes, this is regressed.
It is not dup of bug297288. 

In 1.8branch build to 2005-10-24, the Porxy server name and port number, and Auto Proxy URL, all migrate. 
Possibly a regression from bug 313529. See also bug 316995.

Comment 4

12 years ago
Nominating for next release(es) since this might be a regression from mconner's latest migration code changes. Assigning to him for more investigation.
Assignee: nobody → mconners
Flags: blocking1.8.1?
Flags: blocking1.8.0.1?

Updated

12 years ago
Keywords: regression
Assignee: mconners → mconnor
Flags: blocking1.8.0.1? → blocking1.8.0.1-
(Assignee)

Comment 5

12 years ago
Created attachment 209567 [details] [diff] [review]
patch of trunk

In trunk, "RegKey" is used undefined. 
http://lxr.mozilla.org/mozilla/source/browser/components/migration/src/nsIEProfileMigrator.cpp#1872
(Assignee)

Comment 6

12 years ago
In 1.8branch, because bug-org250255 is not corrected, logic is somewhat different. 
But  after the registry is opened with RegOpenKeyEx in place, it doesn't close. 

After the same key is open and is used in the following places, it doesn't close. 
http://lxr.mozilla.org/mozilla1.8/source/browser/components/migration/src/nsIEProfileMigrator.cpp#1840
http://lxr.mozilla.org/mozilla1.8/source/browser/components/migration/src/nsIEProfileMigrator.cpp#1867

Does not the error occur when opening without closing the same key?
(Assignee)

Comment 7

12 years ago
Created attachment 209570 [details] [diff] [review]
patch of 1.8branch

RegCloseKey is called at the right time.
Assignee: mconnor → crot0
well, are we taking 250255 on the branch (with this fix)

we should absolutely fix this in both places...
Blocks: 250255
(Assignee)

Comment 9

12 years ago
Created attachment 209651 [details] [diff] [review]
Patch of correct 1.8.0branch

Miss spelling Key -> key
Attachment #209570 - Attachment is obsolete: true
(Assignee)

Comment 10

12 years ago
In test build that applied patch to current source(trunk/MOZILLA_1_8BRANCH), the Proxy setting was correctly reflected. 
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 11

12 years ago
If bug266413 along with this problem doesn't do FIXED, Firefox cannot be immediately used by setting IE migration. 

When setting migration of IE is executed, it is necessary to be able to use it without doing anything in the next release. 

Comment 12

12 years ago
Comment on attachment 209567 [details] [diff] [review]
patch of trunk

Thanks for catching my stupid mistake.
Attachment #209567 - Flags: ui-review?(darin)
Attachment #209567 - Flags: review?(cbiesinger)

Comment 13

12 years ago
Comment on attachment 209567 [details] [diff] [review]
patch of trunk

oops. sorry for spam. I meant to ask Darin for sr.
Attachment #209567 - Flags: ui-review?(darin) → superreview?(darin)

Comment 14

12 years ago
(In reply to comment #9)
> Created an attachment (id=209651) [edit]
> Patch of correct 1.8branch
> 
> Miss spelling Key -> key

I'll ask for approval for landing of attachment 188853 [details] [diff] [review] with your fix in 1.8.1 branch so that you don't have to worry about making a separate branch fix. THanks anyway



Comment 15

12 years ago
Comment on attachment 209567 [details] [diff] [review]
patch of trunk

sorry for spamming once more. I can just r this.
Attachment #209567 - Flags: review?(cbiesinger) → review+
Comment on attachment 209567 [details] [diff] [review]
patch of trunk

r=me fwiw :)

Updated

12 years ago
Attachment #209567 - Flags: superreview?(darin) → superreview+
checked-in. Thank you, Hiro-san.

Jungshik:

What do you think for branch?
Bug-org 250255 will go to 1.8.1 and 1.8.0.x?
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 18

12 years ago
(In reply to comment #17)

> What do you think for branch?
> Bug-org 250255 will go to 1.8.1 and 1.8.0.x?

Thanks for bringing that up. I forgot about that. I guess my patch will go in for 1.8.1 only. So, you may go ahead and ask for a1.8.0.2 for attachment 209651 [details] [diff] [review]. 

Comment on attachment 209651 [details] [diff] [review]
Patch of correct 1.8.0branch

O.K. Thanks. Please review this for formal process.
Attachment #209651 - Attachment description: Patch of correct 1.8branch → Patch of correct 1.8.0branch
Attachment #209651 - Flags: superreview?(darin)
Attachment #209651 - Flags: review?(jshin1987)
Flags: blocking1.8.0.2?

Comment 20

12 years ago
Comment on attachment 209651 [details] [diff] [review]
Patch of correct 1.8.0branch

r+sr=darin
Attachment #209651 - Flags: superreview?(darin)
Attachment #209651 - Flags: superreview+
Attachment #209651 - Flags: review?(jshin1987)
Attachment #209651 - Flags: review+
Attachment #209651 - Flags: branch-1.8.1?(bugs)
Attachment #209651 - Flags: approval1.8.0.2?
Comment on attachment 209651 [details] [diff] [review]
Patch of correct 1.8.0branch

We don't need this for 1.8.0 branch. See comment 18. Thanks.
Attachment #209651 - Flags: approval1.8.0.2?
Comment on attachment 209651 [details] [diff] [review]
Patch of correct 1.8.0branch

Sorry. This should go to only 1.8.0 branch.
Attachment #209651 - Flags: branch-1.8.1?(bugs) → approval1.8.0.2?
(Assignee)

Comment 23

12 years ago
(In reply to comment #14)
> I'll ask for approval for landing of attachment 188853 [details] [diff] [review] [edit] with your fix in 1.8.1
> branch so that you don't have to worry about making a separate branch fix.

Because this had done checkin, 1.8branch NB Firefox was tried. 
But the item that had been defined as follows did not migrate. 
And Proxy and SSL too.

Homepage, cookie, and User Style Sheet did migrate. 

http://lxr.mozilla.org/mozilla1.8/source/browser/components/migration/src/nsIEProfileMigrator.cpp#326

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060206 Firefox/1.5
Created attachment 211008 [details] [diff] [review]
Trunk vs 1.8 branch

This is diff between trunk and 1.8 branch.
I think that there is no problem...
I cannot reproduce this bug on 1.8 branch.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20060207 Firefox/1.5

Hiro-san, please re-test it.
(Assignee)

Comment 26

12 years ago
It tested again with following build.
But not migate...
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/firefox-1.5.en-US.win32.zip

In trunk build, no problem.


Windows XP Pro SP1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060207 Firefox/1.5

Comment 27

12 years ago
(In reply to comment #24)

> Trunk vs 1.8 branch
> 
> This is diff between trunk and 1.8 branch.
> I think that there is no problem...

Yeah, I also made this diff and can't see anything that can possibly makes a difference between two as far as migrating proxy configuration is concerned.
This bug doesn't appear to be on the 1.8.0 branch, what problem is attachment 209651 [details] [diff] [review] trying to solve?
Flags: blocking1.8.0.2? → blocking1.8.0.2-
yeah, you're right. I cannot reproduce this problem on 1.8.0 branch too.
We don't have any checked-in to migrator code of 1.8.0 branch.
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA_1_8_0_BRANCH&branchtype=match&dir=mozilla%2Fbrowser%2Fcomponents%2Fmigration%2Fsrc&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-08-01&maxdate=2006-02-10&cvsroot=%2Fcvsroot

But Mozilla Japan has other same report from our partner company...
# Of course, on Fx1.5.

Hiro-san:

Can you reproduce this on 1.8.0 branch?
Oh, I understand. The problem doesn't occur by [File] -> [Import].
But I can reproduce this at clean installed first boot time(all profiles removed).

I can reproduce on 1.8 branch too. Comment 26 is right.
Daniel:

I confirmed that the first boot time importing problem is fixed by attachment 209651 [details] [diff] [review]. Let's go to 1.8.0.2.
It's strange...

I tested on MOZILLA_1_8_BRANCH CVS build. This bug is fixed on the build too. But the official nightly build(*) has this bug...

(*) I got from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/
This bug still exists when the build uses official branding.
I separated the issue to bug 327306.
Comment on attachment 209651 [details] [diff] [review]
Patch of correct 1.8.0branch

Looks like the 1.8.0.x problem was solved in bug 327303/327306
Attachment #209651 - Flags: approval1.8.0.2? → approval1.8.0.2-
(In reply to comment #34)
> (From update of attachment 209651 [details] [diff] [review] [edit])
> Looks like the 1.8.0.x problem was solved in bug 327303/327306
> 

Yeah, you're right. This is fixed by bug 327303.
*However*, I think that this is resource leak bug.
Should we fix this on 1.8.0.x, right?
You need to log in before you can comment on or make changes to this bug.