Does not cope with Mail Inbox over 2gb in size (Alternative provided)

RESOLVED DUPLICATE of bug 9309

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 9309
13 years ago
11 years ago

People

(Reporter: David Booth, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

I get hundreds of useful emails with attachments a week. In general I get about 2GBs every 3 months. Storage is not a problem, simply storing all emails and attachments in a single inbox file is!

Alternative would be to store each email with its attachment in a seperate file. ***Dont want to simply strip attachment from Email as it probably will be de-linked (moved/deleted) accidently at some point***

Reproducible: Always

Steps to Reproduce:
1.recieve more than 2gbs worth of data (can be separate emails)
2.
3.

Actual Results:  
Simply stops downloading any new email (without warnings!)

Expected Results:  
At very minimum, warn user and still allow user to delete email from inbox and compact (Outlook express wont let you. Once reached file limit, thats it!)

Simply dealing with larger than 2GB files will fix it for now, but only be a hack at best.

Require a proper fix, i.e. not storing all emails in single inbox file.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 9309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

11 years ago
I disagree that "TB is completely ignorant about bigger than 2GB mbox" is the same as "attachments should be stored separately".

About the 2GB limit: This is the third millenium. Storage is measured in terabytes. Please get TB up to speed. Thanks.
You need to log in before you can comment on or make changes to this bug.