Aged Junk Mail folder entries "older than" are not deleted.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: painterengr, Unassigned)

Tracking

1.7 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-02-15)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915

With dialog tools->junk_mail-controls check "enable junk mail controls", "move incoming messages determined to be junk mail to:", "junk folder on:", "automatically delete junk messages older than", and set, say 14 in "days from this folder".

Over time junk mail messages accumulate in the junk folder.  At some point longer than the number of days specified one should see message get deleted.  This does not happen.  It never deletes any messages from the junk folder, even months and years old.

Reproducible: Always

Steps to Reproduce:
1. Set junk mail controls as described in Details above.
2. Allow the JMC to accumulate messages in the junk folder.
3. After the number of days specified examine the junk folder to see messages that should have been deleted.

Actual Results:  
Junk folder messages older than the nubmer of days specified never get deleted.

Expected Results:  
Junk folder messages older than the number of days specified in the JMC settings should be automatically deleted.
Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051103 SeaMonkey/1.0b
(In reply to comment #1)
> Confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8)
> Gecko/20051103 SeaMonkey/1.0b
I have to draw back this confirmation. It worked now and the old junk mails got deleted.

Comment 3

13 years ago
richard,

Can you reproduce this problem in the SeaMonkey 1.0a release (see http://www.mozilla.org/projects/seamonkey/)?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> richard,
> 
> Can you reproduce this problem in the SeaMonkey 1.0a release (see
> http://www.mozilla.org/projects/seamonkey/)?
> 

Unfortunately I have not installed seamonkey and will not be able to for a while.

Comment 5

13 years ago
Mesages are not deleted from junk folder for e-mail moved by message filters to different account folder.  Case for unmoved mail not verified. Mozilla 1.7.12, win2000 OS 

Note: Most of my e-mail is forwarded to local service provider e-mail and filters are used to sort into original to addresses and reply from those addresses. 

Comment 6

13 years ago
*** Bug 333957 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: mail → nobody
Component: MailNews: Main Mail Window → MailNews: Filters
Product: Mozilla Application Suite → Core
Version: unspecified → 1.7 Branch

Comment 7

12 years ago
JUNK status must be set on message or it won't be deleted, even if it's in the junk folder.

if this works for you or the bug goes away for you, then please comment in this bug.

1.7 users should change to Seamonkey 1.1 when it comes out, it will have some fixes to junk mail processing.
QA Contact: filters
(Reporter)

Comment 8

12 years ago
I'm now running 1.7.13 and it still is showing entries in the JUNK folder older than the cutoff.  HOWEVER, these old ones are NOT marked as junk.  BUT they were never dragged here.  I NEVER drag items around.  These items were specifically DELETED using the "delete" button. So, either this is a bit different than what I originally reported by virture of not properly deleting old junk items OR it is a NEW problem with DELETE where items are not going to trash but instead incorrectly going into JUNK.

In any case, the latter is true now.  If you want me to open a new bug for this I will.

rich

Comment 9

11 years ago
Rich, do you still see this problem?  It is the only bug reported about "older than" setting, so it seems unlikely to be a real bug.
Summary: Aged Junk Mail folder entries are not deleted. → Aged Junk Mail folder entries "older than" are not deleted.

Comment 10

11 years ago
p.s. regarding comment 8, if you see a new problem with a new, clean profile and there isn't a bug already reported then please file a new one.
Whiteboard: closeme 2008-02-15
Resolving incomplete closeme bugs that do not have sufficient information.

Please comment if the issue still occurs in the latest supported Thunderbird version 2.0.0.12 or trunk nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.