If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

opening modal dialog from menu leaves menu name white

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
12 years ago
5 years ago

People

(Reporter: Martin Meyer, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20051116 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20051116 Firefox/1.6a1

When I opened my About dialog today I noticed that the Help menu text remained white until I closed the dialog.  This seems to be the case with any modal dialog such as Save As too.

This problem does not occur with non-modal dialogs.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Open the Help menu, select About Mozilla Firefox

Actual Results:  
Dialog opens and the Help menu name is white instead of black.

Expected Results:  
That menu name shouldn't be white.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051116 Firefox/1.6a1 ID:2005111606

WFM

Comment 2

12 years ago
I can confirm this bug.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051130 Firefox/1.5

Comment 3

12 years ago
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051207 Firefox/1.6a1 ID:2005120705
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

12 years ago
Created attachment 205281 [details]
screenshot from 1.5 final on Gentoo

This is a clip of a screenshot from a 1.5 release build in Gentoo.  It's not just on Trunk apparently :-(
(Reporter)

Comment 5

12 years ago
I think this problem is caused by one of the patches Gentoo applies to their Firefox build but I haven't determined exactly which one.  I have filed a bug with Gentoo (http://bugs.gentoo.org/show_bug.cgi?id=118350) and I think this bug should probably be resolved to invalid.

Comment 6

8 years ago
I have this Bug on Ubuntu with Firefox 3.6 and Firefox 3.7, but not Firefox 3.5:

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b1pre) Gecko/20090926 Ubuntu/9.04 (jaunty) Namoroka/3.6b1pre
No recent reports of this, old bug -> WFM
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.