"select" form elements do not follow page scrolling with mouse wheel

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Marco De Vitis, Unassigned)

Tracking

1.5.0.x Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/09, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

If you open a listbox ("select" form elements) in a web page by clicking on it, then move the mouse away from it while leaving it open, and then scroll the page up or down using the mouse wheel, the listbox stays still, not following the page during scrolling, or even goes crazy and jumps out of the window.

Reproducible: Always

Steps to Reproduce:
1. Visit any web page containing a form which includes a listbox, e.g. http://www.cnet.com/
2. Click on the listbox (showing "All CNET" in my example) to make it open; the example one will show 2 items.
3. Move the mouse pointer away from the listbox.
4. Scroll the page down/up with the mouse wheel.

Actual Results:  
The listbox more or less stays in the same place where it was, while the page scrolls under it. It's "more or less" because it also seems to try to catch up late with the page, but this causes even stranger effects: if you scroll down fast then the listbox can temporarily appear outside the page area, or even over the OSX menu bar!

Expected Results:  
The open listbox should scroll smoothly together with other page elements.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/09
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

11 years ago
No problem anymore in Firefox 2.0.0.4 on OSX 10.4.9 PPC: the open listbox still does not move together with the scrolling page, but it is faded away as soon as you start scrolling (just like when you move the focus out of it), so there is no GUI corruption.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.