todo panel needs to support multiple, sortable columns

VERIFIED FIXED in 0.7

Status

VERIFIED FIXED
13 years ago
11 years ago

People

(Reporter: dmose, Unassigned)

Tracking

unspecified

Details

(Reporter)

Description

13 years ago
at the very least, date and priority

Comment 1

13 years ago
The current to-do list in Lightning is an implementation of the new <richlistbox> xul-element.  A richlistbox, however, does not support columns at all.  This means our options are:
1.) Hack/extend richlistbox to support columns
2.) Scrap the richlistbox in favor of a standard tree, a la Sunbird.

Option 1 is likely to be much harder than option 2.  However, if we could actually accomplish option 1, a whole world of possibilities would open up, given the vast flexibility of <richlistitem>s.  In-line editing is the most obvious.  Again, there are a lot of question marks here.  We need to pick a path to go down.
(Reporter)

Updated

13 years ago
Assignee: nobody → jminta

Comment 2

13 years ago
I started working on a nice, pretty xbl binding for lists/trees in calendar.  It's not finished yet though, and given current resources/timelines, I'm inclined to just try to write a shim to get Sunbird's task list into Lightning for the 0.1 release.  Opinions?
(Reporter)

Comment 3

13 years ago
Sounds reasonable to me.
(Reporter)

Comment 4

13 years ago
It'd be nice to have this for 0.1, but it's more important to ship something sooner, I think.
No longer blocks: 298366
Target Milestone: --- → Lightning 0.2
*** Bug 349535 has been marked as a duplicate of this bug. ***
Not going to make the 0.3 train.
Target Milestone: Lightning 0.3 → Lightning 0.5
Not going to make the 0.5 train.
Target Milestone: Lightning 0.5 → ---
Moving bugs from Joey without a patch back to nobody, since Joey has basically left the project.
Assignee: jminta → nobody
Duplicate of this bug: 383693
This should be fixed by the changes from Bug 372830.
Depends on: 372830
Fixed by the checkin for Bug 372830.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7

Comment 12

11 years ago
Verified with lightning 2007092403
Status: RESOLVED → VERIFIED
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.