Sidebar needs a close box (to do same as View->Sidebar)

VERIFIED DUPLICATE of bug 33420

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 33420
19 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: shuang (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From discussions on the .ui newsgroup:

Peter Trudelle wrote:
> 
> Sebastian Spaeth wrote:
> 
> > > > The sidebar sucks, how do I get rid of it?
> >
> > I really wonder why people are asking this all the time? I personally
> > think is not so difficult to find and View->Sidebar(checked/unchecked)
> > is pretty intuitive, isn't it?
> 
> If people are asking this all the time, that pretty much answers your second
> question.  This is probably why MS put an 'X' close button on theirs.
> 

So it seems like it would be a good idea to add a close box somewhere so that 
it's more intuitive.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

19 years ago
Yes. Ideally it should use an OS-specific overlay; so it can appear as a cross on 
the right side of the sidebar header in Windows, and a square on the left side of 
the sidebar header in MacOS.

Comment 2

18 years ago
QA Assigning non-confidential New/Assigned User Interface: Design Feedback bugs 
to Matthew Thomas (mpt@mailandnews.com).

Matthew Thomas is now the QA owner for the User Interface: Design Feedback 
component. (Bugs that involve UI issues in the Netscape-branded Mozilla browser 
should continue be QA assigned to elig@netscape.com.)
QA Contact: elig → mpt

Comment 3

18 years ago
It's a good thing to have, and pretty much universal in sidebar-type things
today (which is why so many people expect that to be the way to close the
thing), but the sidebar overlay isn't really designed around this idea.

The problem being the "Tabs >" (formerly "New >") menu[bar/button] on the right
side. This makes putting another button on the right slightly crazy, and putting
one between the title and "Tabs" is even more so.

I can think of a few placements:
--put a down arrow on the "Tabs" button and then put the quick close button
wherever we want
--an X close button on the left side. That way everyone should understand what
it's for. (Even poor inflexible win/mac users.)
--make "Tabs" into "Menu", and include "Close sidebar" among the choices. Not
exactly the asked-for feature, but close.

I like the middle one, and I could implement this pretty easily (with a little
help from the skin designers.)

Comment 4

18 years ago
Or, make the menu title `My Sidebar', instead of using a separate menu.

Comment 5

18 years ago
Marking this a duplicate of bug 33420, which has a lot more discussion in it.

*** This bug has been marked as a duplicate of 33420 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dup. (Hmmm, should have spotted that earlier.)
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.