Preferences do not hold between sessions

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: tomkeller, Assigned: mikepinkerton)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.2; Mac_PowerPC)
Build Identifier: 1.0b1

Neither the home page nor the history preferences hold after I quit Camino and then open it again. I have not looked at the other preferences.

A previous report of this problem indicates that the problem has been resolved. However, it is not resolved in my computer. Running Mac OS X 10.3.9.

Reproducible: Always

Steps to Reproduce:
1. Open preferences. 
2. set home page to blank and history to 2 days. 
3. Quit Camino.
4. Re-open Camino.

Actual Results:  
Home page reverts to Mozilla and history to 0 days, apparently the default.

Expected Results:  
Retained the preferences.
Can you move aside your ~/Library/Application Support/Camino folder and start Camino (that will force Camino to recreate a new profile folder), set some prefs, and see if they stick now?
(Reporter)

Comment 2

13 years ago
> Can you move aside your ~/Library/Application Support/Camino folder and start
> Camino (that will force Camino to recreate a new profile folder), set some
> prefs, and see if they stick now?

Tried it, putting the subject folder in the trash (did not empty it). History and home page preferences did not stick. 


where is your home directory? local machine or a netboot server? sounds like we're not writing any prefs for some reason.

also, maybe try repairing permissions, maybe you don't have write access to that part of your account?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> where is your home directory? local machine or a netboot server? sounds like
> we're not writing any prefs for some reason.
> 
> also, maybe try repairing permissions, maybe you don't have write access to
> that part of your account?

Local machine. Tried repairing permissions. No effect. I have administrator privileges or whatever they are called. Checked another preference, security. Changed the preference there. Did not hold. If of any help, I am running OS X 10.3.9. I also tried resetting Camino. No positive effect.

If you launch Camino, change some prefs, and quit Camino, do you see anything in your Console.log (accessed via the Console.app in /Applications/Utilities)?

(There will be lots of stuff in the log, but does anything get written from the time you launch Camino until it has completely quit?  There will be a number of lines like 
Feb  4 08:34:42 Krak-des-Chevaliers /Applications/Internet/Camino.app/Contents/MacOS/Camino: objc: Both /Applications/Internet/Camino.app/Contents/PreferencePanes/Appearance.prefPane/Contents/MacOS/Appearance and /Applications/Internet/Camino.app/Contents/PreferencePanes/Downloads.prefPane/Contents/MacOS/Downloads have implementations of class PreferencePaneBase.
but they are normal.)
Tom, can you please update us on the questions in comment 5?
Whiteboard: [CLOSEME - 03/01/06]
Closing WFM due to lack of updates.  If you can supply the requested information, you may reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [CLOSEME - 03/01/06]
(Reporter)

Comment 8

13 years ago
Did not spend the time looking at the log. To be frank, I just went back to Safari.

At some point, the preferences started to hold again. May have been with a new version of Foxfire that I downloaded.

All is well now.
You need to log in before you can comment on or make changes to this bug.