If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Yahoo Mail spell check always suggests the word 'your' for every error in spelling with Mozilla recently.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: mkabe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

When using Yahoo Mail and the Mozilla Browser the spell check function on Yahoo Mail will ONLY suggest the word 'your' as the "change to" word no matter what word checked or how it is spelled incorrectly.  It will identify correctly spelled words but recommends 'your' for everything else, the "Suggestions" box is empty.  It does not happen when using Yahoo Mail and Internet Explorer, only with Mozilla and on two different machines.
It started approx. two weeks ago, early Nov. but had worked fine for the many months I have been using Mozilla.  I uninstalled Mozilla with the "Add/Remove Programs" fucntion and reinstalled but it did not correct the problem.
A friend trying to duplicate the problem said Mozilla and the Yahoo spell check worked for him, as it had for me on my two machines for months.
Thanks,

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Go to Yahoo Mail and compose text with a, or several, misspelled words
3. check spelling

Actual Results:  
every misspelled word when checked with yahoo mail spell check suggests the word 'your'

Expected Results:  
a suggested CORRECT spelling of the word I was wanting to use but instead I got the word 'your'

suggested a 'change to' whatever the correct spelling is and list other 'suggestions' but not show the word 'your' everytime for every word.
thanks,
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051117 Firefox/1.6a1 ID:2005111723

This works for me (tried only the latest version).
(Reporter)

Comment 2

12 years ago
This bug is occurring with both Windows XP and 98.
Can you reproduce the problem in the safemode? http://www.mozilla.org/support/firefox/faq#troubleshooting

Comment 4

12 years ago
Here are the errors from the Javascript console:

Error: ylib_keyevt is not defined
Source File: http://us.f545.mail.yahoo.com/ym/ShowLetter?MsgId=6449_5177029_510615_1474_629_0_144677_1591_199084195&Idx=0&YY=63535&inc=50&order=down&sort=date&pos=0&view=&head=&box=Inbox
Line: 279

Error: MenuButton is not defined
Source File: http://us.f545.mail.yahoo.com/ym/ShowLetter?MsgId=6449_5177029_510615_1474_629_0_144677_1591_199084195&Idx=0&YY=63535&inc=50&order=down&sort=date&pos=0&view=&head=&box=Inbox
Line: 1102

Comment 5

12 years ago
You're using a very old version of firefox, and frankly I don't see how this is a browser bug.
(Reporter)

Comment 6

12 years ago
The problem went away after downloading Mozilla 1.5 when it became available.

Comment 7

12 years ago
*** Bug 335702 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
*** Bug 315505 has been marked as a duplicate of this bug. ***
works for me with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4 also confirmed wfm by the reporter in comment #6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.