Double clicking on a word that has been formatted, causes the word after this word to be highlighted also.

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: js-777, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Double clicking on a word while composing a Yahoo e-mail before using the Firefox format extension, highlights just that word, as expected.
But, after formatting a word, double clicking on it causes the word After to also be highlighted.
And, if the user double clicks on the word before the formatted one, all three words are highlighted,.....the one clicked on, the formatted one, and the word after the formatted one.

Reproducible: Always

Steps to Reproduce:
1. In Yahoo Mail, click on the "Compose" button.
2. Enter in some text that has five or more words in it (to see it better).
3. Double click on a word. Notice that just that word and the space after it is highlighted.
4. Highlight one of the words in the middle and click on the Bold format button.
5. Double click on the bolded word.

Actual Results:  
The bolded word AND the word after it is highlighted.

Double clicking on the word before the bolded word causes ALL three words to be highlighted......the one before and the one after the bolded word.

Expected Results:  
That double clicking on a word after it has been formatted would still only highlight just that word, like it does before formatting.
Copied from bug 316932

I'm unsure of which extension you are referring to but which ever extension is causing the problem it is not an Extension Manager bug since the Extension Manager manages extension install, upgrade, uninstall, etc. and does no control how an extension interacts with the application. This problem will most likely need to be fixed with the extension itself so please let the author know about this. You can usually find the extension's home page by right clicking it in the Extension Manager and selecting visit home page.

BTW: I know of no extension named "Firefox format extension" - please provide a link when you are referring to an extension having problems. Even so, if the problem does not occur without the extension then it is most likely not a Firefox bug and the extension author will need to fix the problem in the extension itself.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
The "eWebMail Color and Graphics - Firefox Extension" is downloaded from
https://addons.mozilla.org/extensions/moreinfo.php?id=389

This does not occur in IE6.

(Although, I did notice that this format bar did change (visually) a few weeks later after I had installed it. I thought this change was the latest version since I ran Firefox's 'updates' button.)

This bug is occurring when using the Firefox browswer 1.0.7.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
See bug 316932 comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
I e-mailed the author, "Harry Patsis", and gave him the URLs to these two bugs in Bugzilla.

Thanks! :)
(Reporter)

Comment 5

13 years ago
OK.
Looks like that comment was added just 11 minutes ago.

Yahoo is now supporting Firefox for this feature, and now it is a Yahoo issue.

Closing bug.

Thanks! :)
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.