porsche.de - CarConfigurator does not start

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: m.mlinar, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051107 Firefox/1.5

Trying to start the CarConfigurator of www.porsche.de opens an window but shows no content for Firefox 1.5
After deinstalling 1.5 and installing of 1.0.7 the Configurator works fine ...

Reproducible: Always

Steps to Reproduce:
1. start www.porsche.de
2. klick CarConfigurator
3.

Actual Results:  
no content is shown in the new window

Expected Results:  
chosse between 2D and 3D Version of the Configurator

works fine after switching from Firefox 1.5 to 1.0.7

Updated

13 years ago
Summary: CarConfigurator does not start → porsche.de - CarConfigurator does not start

Comment 1

13 years ago
Strange, with SeaMonkey trunk it works for me, with FF trunk it does not. Both have JS enabled...

Comment 2

13 years ago
Ok, i wrote a mail to them explaining the problem, the problem is in the file http://cc.porsche.de/pva/mimes/pva/scripts/functions_basic.js this code-line:
this.version = parseFloat(ua.replace(/^.*firefox\/(\d+)\.(\d+)\.(\d+).*$/, "$1.$2$3"), 10);

It thinks every FF version has the format x.y.z, which is not true for FF 1.0 (but for FF 1.0.x) and not for FF 1.5. For those cases it has sent BV=NaN to the server which it did not like and so sent back a white page.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Received a response, problem is already known, will be fixed in a future version of the CarConfigurator.

Comment 4

13 years ago
Works fine now with Firefox 1.5, Firefox 1.5.0.4 and a SeaMonkey trunk build.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.