Weird Grouped By Sort behavior when receiving new e-mail

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
trivial
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Cyriel van 't End, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-09-04)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: 

I've installed Thunderbird 1.5 RC1 yesterday and everything looked just right before receiving new e-mail this morning. After I received new e-mail it looks like the Messages view doesn't update correctly (the mail i received yesterday doesn't have the 'Yesterday' header anymore but has been replaced by the details of the e-mail i received yesterday!). When I change views however (e.g. switch to another mail folder) everything looks fine again.

Reproducible: Always

Steps to Reproduce:
1. Make sure you didn't receive any e-mail until yesterday
2. Make sure you have navigated to the place where some new email is stored (usually Inbox, except when you have applied all kinds of rules)
3. Make sure this location has been sorted using "Group By Sort"
4. Fetch new e-mail using the "Get Mail" button
5. Take a look at the Messages view
6. Navigate to another item in the Navigation tree
7. Navigate back to the item you came from within the Navigation tree
8. Take a look at the Messages view again

Actual Results:  
The "Yesterday" header has been mysteriously replaced by the message details of the  e-mail message I received yesterday

Expected Results:  
Keep the "Yesterday" header shown
(Reporter)

Comment 1

12 years ago
Created attachment 203497 [details]
This screenshot shows the weird behavior in action
(Reporter)

Updated

12 years ago
Attachment #203497 - Attachment description: This screenshot shows the behavior in action → This screenshot shows the weird behavior in action
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5
(Reporter)

Comment 2

12 years ago
Apparently this only behavior shows up only when receiving one new e-mail. If I receive multiple emails the Messages view behaves like it should.
QA Contact: front-end
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is 2.0.0.16)
Whiteboard: closeme 2008-09-04
(Reporter)

Comment 4

10 years ago
It looks like this particular issue doesn't show up in the 2.x branch (at least not in the 2.0.0.16 version I'm using).

Marked as fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
-> WFM. Fixed is used for bugs with known patches.
https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 6

10 years ago
Crap, thanks Gary. Think it's time for some coffee... :)
You need to log in before you can comment on or make changes to this bug.