clipboard trouble with Outlook 2000: copying text to clipboard in Firefox also seems to store URL, which messes up paste in Outlook

RESOLVED DUPLICATE of bug 311020

Status

()

Firefox
Shell Integration
--
minor
RESOLVED DUPLICATE of bug 311020
13 years ago
13 years ago

People

(Reporter: Jason Sachs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Step 1: From Firefox, copy any text on page into clipboard using Ctrl-C
Step 2: Open Outlook 2000, compose a message in Plain Text Format
Step 3: Paste text with Ctrl-V. Instead of the plain text being copied, it adds an attachment which is a URL link to the page in question.
(Step 4: Compose a message in Rich Text / HTML format & paste -- it pastes the selected text as formatted text, properly. Or open Notepad & paste, and it will work correctly.)

My guess (although I don't have a clipboard viewer to see which formats are being stored) is that Firefox is now including the URL of the page from which the text in question was copied. For some reason, Outlook 2000 chooses this clipboard format, when in plain text mode, as a higher priority than just getting the plain text.

My previous version of Firefox (1.0 I think) did not do this, it pasted plain text properly.

While this is certainly Microsoft's fault & boneheadedness for choosing the URL format ahead of the plain text (if both are available), I would really appreciate the option in Firefox to not include the URL as one of the data formats copied to the Clipboard. I never intend to use it in that way, and it makes it much more inconvenient for me to copy data, as plaintext, to a composed message.

(Yes I would much rather be Outlook-Free and use Thunderbird, but at this company that is not an option.)

Reproducible: Always

Steps to Reproduce:
See details

Actual Results:  
See details

Expected Results:  
See details

Comment 1

13 years ago
Duplicate of bug 311020?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Duplicate of bug 311020?
> 

looks like it. Sorry. I thought I had done a sufficient job searching through the database.

*** This bug has been marked as a duplicate of 311020 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.