Closed Bug 316994 Opened 14 years ago Closed 14 years ago

Pressing "Clear" does not reset console state

Categories

(Toolkit Graveyard :: Error Console, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 238898

People

(Reporter: mozilla, Unassigned)

Details

20051117 trunk

1. Open Javascript console and put in some JS to evaluate.
2. Press "Evaluate".
3. Press "Clear".
4. Press "Evaluate" again.

RESULT:
Nothing.

EXPECTED:
The Javascript should have evaluated.
Actually, no.
It just never re-evaluates the same code for some reason, even if you clear.  Try skipping Step 3 and you will see the same result.

Suggested to mark as dupe of bug 238898 (which is about the lack of re-evaluation).
It's not the clear that does it. It's that the state of the JS is not reset on clear so that the expression is not evaluated if it's the same as the last time "evaluate" was pressed.

*** This bug has been marked as a duplicate of 238898 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Summary: Pressing "Clear" blocks all further evaluate operations → Pressing "Clear" does not reset console state
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.