Page cannot be refreshed if network outage occurs during load

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: Joshua Bowman, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefoxy Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If a temporary network outage occurs while loading an http resource, that resource will not load and will remain unloadable until the cache is cleared. Any attempt to reload it before then times out in a second and presents the same blank page. (No "connection reset, try again" either.)

I have not yet sniffed the line to determine whether it is even querying the server.

Reproducible: Sometimes

Steps to Reproduce:
1. Load http://www.squarefree.com/burningedge/releases/
2. Unplug network cable
3. Click a link and let it time out.
4. Plug cable back in, then refresh (or click in the address bar and hit enter). Alternately, try going back and then click the same link again.
Actual Results:  
Page (usually) does not load and cannot be loaded without clearing the cache.

Expected Results:  
Page should load normally.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051118 Firefox/1.6a1 ID:2005111805

WFM, can't reproduce.

Comment 2

10 years ago
WFM per comment 1.
please reopen if you see otherwise using version 2 or current trunk build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.5.0.x Branch
You need to log in before you can comment on or make changes to this bug.