Create plugin mechanism to use clamd to scan attachments

RESOLVED DUPLICATE of bug 372974

Status

()

Bugzilla
Attachments & Requests
--
enhancement
RESOLVED DUPLICATE of bug 372974
12 years ago
9 years ago

People

(Reporter: Joel Peshkin, Assigned: Joel Peshkin)

Tracking

Details

(Assignee)

Description

12 years ago
Since it would be very bad form to pass a virus through a bug, it would be useful for many sites to virus scan attachments.  The plugin should interface to clamd but be flexible enough to permit other approaches.  It should stay out of the way if not enabled.

Comment 1

11 years ago
This bug is retargetted to Bugzilla 3.2 for one of the following reasons:

- it has no assignee (except the default one)
- we don't expect someone to fix it in the next two weeks (i.e. before we freeze the trunk to prepare Bugzilla 3.0 RC1)
- it's not a blocker

If you are working on this bug and you think you will be able to submit a patch in the next two weeks, retarget this bug to 3.0.

If this bug is something you would like to see implemented in 3.0 but you are not a developer or you don't think you will be able to fix this bug yourself in the next two weeks, please *do not* retarget this bug.

If you think this bug should absolutely be fixed before we release 3.0, either ask on IRC or use the "blocking3.0 flag".
Target Milestone: Bugzilla 3.0 → Bugzilla 3.2

Updated

11 years ago
Depends on: 372974

Comment 2

10 years ago
Bugzilla 3.2 is now frozen. Only enhancements blocking 3.2 or specifically approved for 3.2 may be checked in to the 3.2 branch. If you would like to nominate your enhancement for Bugzilla 3.2, set the "blocking3.2" flag to "?". Then, either the target milestone will be changed back, or the blocking3.2 flag will be granted, if we will accept this enhancement for Bugzilla 3.2.

This particular bug has not been touched in over eight months, and thus is being retargeted to "---" instead of "Bugzilla 4.0". If you believe this is a mistake, feel free to retarget it to Bugzilla 4.0.
Target Milestone: Bugzilla 3.2 → ---

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 372974
Resolution: --- → DUPLICATE
Duplicate of bug: 372974
You need to log in before you can comment on or make changes to this bug.