text box jumps around on screen when text is entered into it

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: sarnold, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Hello there.

At the debian.org packages website, searching for something with a text input
box in a form submission causes the text input box to jump around. I have not
noticed it elsewhere. (Bugzilla seems to work fine also. :)

I am running a mozilla I built on march 12th from CVS. I built it on a linux
2.0.36 machine, and ran it on a kernel 2.2.13 machine. I am running XFree86
3.3.5, and have a new glibc (2.1.3 iirc).

I was able to reproduce this several times; visit
http://www.debian.org/distrib/packages and type some text into the "keywords"
text entry box under Search Package Directories. The box should jump to the top
of the page (not the top of the display window, but the top of the webpage) and
will work fine otherwise.

I will attach a screenshot.

I am also hoping HTML Element is the correct place, since it involves the input
form elements. It could also belong in Layout.... I am using the ViewManager2.

Please ignore the build-id (I have crossed it out in the image :) because this
is a build made from CVS.

Thank you. :)
(Reporter)

Comment 1

18 years ago
Created attachment 6501 [details]
Note the entry box at the top of the image; it should be near the bottom of the page.

Comment 2

18 years ago
I'm not seeing this on today's nightly build.  Are you still seeing this?
(Reporter)

Comment 3

18 years ago
Yes, these steps can reproduce this bug on my March 25th build:

While viewing this bug report (bug 31704) right-click on the URL link (for
http://www.debian.org/distrib/packages), click the mouse in the Keywords field
under the heading "Search Package Directories" (to give focus) and type -- the
text appears at the very top of the webpage, as attachment 6501 [details] shows.

Again, I build mozilla on a Linux 2.0.36 machine and ran it on Linux 2.2.13.
Both are fairly recent versions of Debian unstable -- updated March 25th.

Thanks :)
sarnold@willamette.edu - are you still seeing this problem on recent builds of 
Mozilla?

Gerv
(Reporter)

Comment 5

18 years ago
A build I made on April 8th still shows this symptom on the URL above (a
debian.org address.)
(Reporter)

Comment 6

18 years ago
I changed my build method, and things seem happier now. :) marking this WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca

Comment 8

18 years ago
Marking VERIFIED.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.