When the href is *exactly* as given the CSS attribute is not applied.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: puckett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Something about the href (according to my testing) is preventing Firefox from applying the CSS style to the link (ie: it's not red).  If I change anything about the url it shows up in red just fine though.  It doesn't - at first glance - seem to be related to the length of the url...

This behavior is not replicated on IE6.

Reproducible: Always

Steps to Reproduce:
1. Go to example website
2.
3.

Actual Results:  
Link text is in the default color.

Expected Results:  
Link text should be displayed in red (as per style rule).
See http://www.falseflag.com/foo1.html (same page except the href is slightly altered)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051118 Firefox/1.5 ID:2005111803

WFM

Comment 2

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

wfm
(Reporter)

Comment 3

13 years ago
After clearing the cache and restarting it now works for me as well.  Should have tried this before submitting the bug.

This perhaps demonstrates that there may be an issue with css and the in-cache dom?  That'd be a different issue/bug though...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.