If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Canvas changes height when opacity changes.

RESOLVED WORKSFORME

Status

()

Core
Canvas: 2D
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: mossop, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

835 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

12 years ago
See the upcoming testcase.

When a canvas element has a border and has its opacity changed from 1 to <1 its height shrinks by the border height and does not return to normal when the opacity returns to 1.

If the opacity begins as <1 (even as 0.9999) the initial height is the same as the opacity 1 case but the height never drops.
(Reporter)

Comment 1

12 years ago
Created attachment 203643 [details]
Testcase

Here is the testcase. The box is a canvas element. Moving the mouse over it will change it's opacity from 1.0 to 0.5.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051119 Firefox/1.5 ID:2005111903

confirmed

Updated

12 years ago
Keywords: testcase
Hrm, I don't think this is canvas itself; maybe roc has some input on what it could be?
This looks like it's worksforme
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.