Starting Camino on a second maching gave "already running" dialog box.

VERIFIED WONTFIX

Status

Camino Graveyard
General
VERIFIED WONTFIX
12 years ago
12 years ago

People

(Reporter: Gerard Hickey, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051107 Camino/1.0b1 

I have my home directory on a OS X server and it is shared out to all the machines in the house. 

I was logged into machine A using Camino. I put machine A to sleep (without closing Camino) and went up stairs to work on machine B. When I attempted to bring up Camino on machine B, I would receive a dialog box stating that Camino is already running on machine B and that two instances could not run at the same time (my paraphrase). After clicking OK on the dialog box, Camino would quit. 

Upon returning downstairs to machine A, found that the home directory share had disappeared. I quit Camino on machine A and returned to machine B upstairs. Machine B continued to display the already running dialog box. 

Once again returned to machine A. Logged out and then back in again to get the home directory share to mount up. Started Camino and then immediately quit it. Then went up to machine B and attempted to start Camino. This time Camino started without any problems. 


Reproducible: Didn't try

Steps to Reproduce:
In theory, the following would reproduce the problem. 

1. Mount the same home directory from machine C on machine A and B. Probably only be able to do it in an Open Directory environment. If needed, I can create a test Open Directory environment on a server in my DMZ for your testing. 
2. Start Camino on machine A. 
3. Put machine A to sleep. My belief is that this step is arbitary and the result is basically the same if the machine is running or asleep. 
4. Attempt to start Camino on machine B. 

Actual Results:  
Just attempted to start Camino downstairs on machine A (while Camino is running on machine B) and received the already running dialog box. Note: on both machines Camino is installed locally and not on a network drive. 

Expected Results:  
I have not yet tracked down what file Camino uses to determine that it is already running. This file is certainly in the user's home directory and probably using a static filename. It probably should have some machine specific portion in the filename like the system serial number or the MAC address. I would suggest not using an IP address as with DHCP the address could change and conflict with a prior execution of Camino (yes, it is rare, but possible). 

Might also be nice to have a details button on the dialog box that more info and the filename that is causing the condition to be displayed.

Comment 1

12 years ago
This is because running two copies using the same profile directory will potentially cause profile corruption, even if they aren't on the same physicial machine.
(Reporter)

Comment 2

12 years ago
Yes, exactly! Camino should allow for different profile directories. In a business environment it is not uncommon to be going between different machines. 

It would be even better to batch up writes to the files and use simple filename locking to prevent corruption. 

If you want to be really fancy, create a thread on on of the browser instances that does all file i/o (cache files should be handle using traditional file i/o) and the other browsers need to register/unregister with the thread. When the primary browser is quit, the thread sends a message out to the registered browsers and a new browser is elected to handle the file i/o. 

Well, those are my few thoughts. Maybe if I have some time in the next couple of weeks I will look at your code and see if some of the above can be easily integrated into the source.
I think supporting multiple profile directories is probably beyond the scope of Camino.

Comment 4

12 years ago
You can have a copy of camino use a different profile dir by editing the "mozNewProfileDirName" key in its Info.plist. So you could hack your own copies to use different dirs.
(Assignee)

Comment 5

12 years ago
yeah, this is WONTFIX, i think.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.