Closed Bug 31715 Opened 20 years ago Closed 20 years ago

[NEWS] silent failure when posting to netscape.champions

Categories

(MailNews Core :: Backend, defect, P3)

x86
All
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sspitzer, Assigned: sspitzer)

References

Details

when I try to post to secnews.netscape.com/netscape.champions (using NNTP over 
SSL) it silent fails.

I'm seeing an assertion in nsMsgNewsFolder::GetGroupPasswordWithUI() because 
aMsgWindow is null.

note, I'm not getting this assertion with a migrated profile (from 4.x)

but I do see it when I create a fresh profile and set it up to read and post to 
that newsgroup.

thanks to jay garcia for finding this bug.
Status: NEW → ASSIGNED
Target Milestone: M15
you need PSM installed to test this.  
http://docs.iplanet.com/docs/manuals/psm/psm-mozilla/index.html#Install

or you need to use the netscape commercial build.

accepting, marking m15.  working on a fix for this now.
QA Contact: lchiang → huang
I don't believe this is exclusive to snews password-protected newsgroups. I can 
reproduce this on NNTP groups as well (no SSL, no PSM involved) - the only 
requirement is that the group require username and password authentication. 
Tested on Win32 only with build 2000031215.
khect19, thanks for the extra info.

the problem is nsMsgMailNewsUrl::GetMsgWindow changed and the nntp wasn't handle 
the case where it couldn't get the msg window properly.

I'm working on a fix now.
checking in the fix.

thanks to jay and khect19.  guys, please continue to use mozilla and log bugs!
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Need to wait for bug#25670 got solved for Linux & Mac platform in order to 
verify this bug. Addint bug#25670 for this bug dependance.....
Depends on: 25670
By using 07-25-09-M17 commercial build for all the platforms:
* For non-secure part: I can successfully post the articles on the non-secure 
password protected news server (poisonivy.mcom.com/xrated)
* But for the secure part:
Since I cannot post the article on netscape.champions, can jay 
(jay@jaygarcia.com)help for verify on the latest Mozilla build to see whether 
this problem got fixed or not? Thanks.
Adding "need help for verify" on the whiteboard.
Whiteboard: need help for verify
Since I didn't get the response from Jay, Ccing Kevin Hecht who may help me for
verifying whether this problem is still occurring on Seamonkey
Secnews/netscape.champoins or not? If I didn't hear the respose from both Jay &
Kevin, I will based on my verification to mark verify for this bug.......
This bug seems to be fixed in the latest builds. Closing Bug
Status: RESOLVED → CLOSED
Thanks Jay for helping verify this bug.
But, we cannot close bugs, we can only marking as verify for bugs.
Let me reopen this bug in order to mark as verify for this bug. 
Thank you very much, Jay!!
Status: CLOSED → REOPENED
Resolution: FIXED → ---
Whiteboard: need help for verify
Mark fixed in order to mark verified.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.