Last Comment Bug 317190 - Change "Check Now" to "Set Firefox as the default browser"
: Change "Check Now" to "Set Firefox as the default browser"
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: All All
: -- enhancement with 1 vote (vote)
: Firefox 15
Assigned To: Christian Ascheberg
:
: Jared Wein [:jaws] (please needinfo? me)
Mentors:
: 606258 (view as bug list)
Depends on: 763232
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-20 08:32 PST by Peter Crocker
Modified: 2012-07-20 16:01 PDT (History)
12 users (show)
jaws: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (5.80 KB, patch)
2012-04-29 15:27 PDT, Christian Ascheberg
robert.strong.bugs: feedback-
Details | Diff | Splinter Review
screenshot (85.84 KB, image/jpeg)
2012-05-01 01:35 PDT, Christian Ascheberg
limi: ui‑review+
Details
patch v2 (10.03 KB, patch)
2012-05-10 17:58 PDT, Christian Ascheberg
jaws: review+
Details | Diff | Splinter Review

Description Peter Crocker 2005-11-20 08:32:16 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Change:
Firefox / Tools / Options / General / Default Browser / [Check Now]

To:
Firefox / Tools / Options / General / Default Browser / [Set Firefox as the default browser]

Then delete the confirmation dialogs since they will be unnecessary.



Reproducible: Always
Comment 1 Angus 2007-11-22 18:02:20 PST
don't agree, I found myself really want to check the current firefox is default browser or not, especially I have multiple version of firefox exist in my system

Another suggestion is directly show "Firefox is not your default browser" and change the button [Set Firefox as the default browser]
Comment 2 Marv Schwartz 2008-04-26 04:49:31 PDT
IE7 has an elegant solution. A single make default button is either active if it is not the default browser or grayed out if it is. It conveys all the information without the dialog box or extra steps and is something I would like to see in Firefox.
Comment 3 Tyler Downer [:Tyler] 2008-11-07 18:23:55 PST
I think the solution in Comment #2 sounds like it could be feasible.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-12-09 10:18:51 PST
*** Bug 606258 has been marked as a duplicate of this bug. ***
Comment 5 Christian Ascheberg 2012-04-29 15:27:41 PDT
Created attachment 619449 [details] [diff] [review]
patch v1

possible patch
Comment 6 Christian Ascheberg 2012-04-30 02:29:31 PDT
(In reply to Christian Ascheberg from comment #5)
> Created attachment 619449 [details] [diff] [review]

It may be nicer to add an additional description with proper label to be shown just after setting the browser as default browser.
Also, I don't know how to really check whether the action was successful (in some cases it needs to be confirmed through Windows UAC, which does not happen immediately).
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2012-04-30 14:34:41 PDT
Comment on attachment 619449 [details] [diff] [review]
patch v1

I am on record in other bugs being adamantly against having extremely long button text so I am going to bow out on this bug except to feedback- the patch and to note that not only will the long text be a problem at the very least for localization but changing the text will likely also likely cause problems with localization. I suggest that you get someone on the UX team involved in deciding what to do here.
Comment 8 Christian Ascheberg 2012-04-30 15:02:11 PDT
(In reply to Robert Strong [:rstrong] (do not email) from comment #7)

It's right that the button text is too long.

Justin Dolske said in https://bugzilla.mozilla.org/show_bug.cgi?id=588297#c5 :
> Quick example:
>
> [X] Check to see if Firefox is default browser on startup.
>     Firefox is currently your default browser.
> 
> [X] Check to see if Firefox is default browser on startup.
>     Firefox is not your default browser. [Make default]
Comment 9 Alex Limi (:limi) — Firefox UX Team 2012-04-30 15:17:55 PDT
Justin's suggestions in comment 8 are close, but I think we can do even better and reduce the happytalk a bit:

When Firefox is already the default browser:

 [X] Check to see if Firefox is default browser on startup.
 Firefox is currently your default browser.

When it's not:

 [X] Check to see if Firefox is default browser on startup.
 [Make Firefox the default browser]

This is more than a couple of words, but better than having the redundant sentence.
Comment 10 Christian Ascheberg 2012-05-01 01:35:51 PDT
Created attachment 619856 [details]
screenshot

same patch, but with text from comment #9
Comment 11 Alex Limi (:limi) — Firefox UX Team 2012-05-09 16:08:21 PDT
Comment on attachment 619856 [details]
screenshot

Looks fine to me — the alignment is a bit off, but I assume this is because you need space for the button even when it's not there. 

In any case, this is a much better interaction flow.
Comment 12 Christian Ascheberg 2012-05-10 17:58:04 PDT
Created attachment 622996 [details] [diff] [review]
patch v2

patch according to screenshot
also updates in-content preferences
Comment 13 Jared Wein [:jaws] (please needinfo? me) 2012-05-11 10:52:37 PDT
Comment on attachment 622996 [details] [diff] [review]
patch v2

Review of attachment 622996 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thanks for also updating the in-content preferences :)
Comment 14 Mozilla RelEng Bot 2012-05-11 16:10:30 PDT
Autoland Patchset:
	Patches: 622996
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/pushloghtml?changeset=13d701c8de0e
Try run started, revision 13d701c8de0e. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=13d701c8de0e
Comment 15 Jared Wein [:jaws] (please needinfo? me) 2012-05-17 12:06:28 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b043e963658
Comment 16 Ryan VanderMeulen [:RyanVM] 2012-05-17 20:40:16 PDT
https://hg.mozilla.org/mozilla-central/rev/7b043e963658

Note You need to log in before you can comment on or make changes to this bug.