firefox crash - flash (16bit xserver) - BadShmSeg

RESOLVED DUPLICATE of bug 304370

Status

()

Core
Widget: Gtk
--
critical
RESOLVED DUPLICATE of bug 304370
13 years ago
12 years ago

People

(Reporter: molikk, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; pl-PL; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; pl-PL; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)

when i go to the wolfemails.net and then i click login firefox had crashed

this is what i get from console 

x@x:~$ firefox
NP_Initialize
New
open dsp: Urz±dzenie lub zasoby zajête
SetWindow
SetWindow
SetWindow
Destroy
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadShmSeg (invalid shared segment parameter)'.
  (Details: serial 35 error_code 168 request_code 148 minor_code 2)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
x@x:~$

Reproducible: Always

Steps to Reproduce:
1. go t the wolfemails.net
2. click login

Actual Results:  
firefox will crash

Expected Results:  
i should go to login page
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch
*** Bug 317211 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
No problems here, FFX 1.5RC2

Updated

13 years ago
Component: General → Widget: Gtk
Keywords: crash
Product: Firefox → Core
QA Contact: general → gtk
Summary: firefox crash → firefox crash - BadShmSeg
Version: 1.0 Branch → 1.7 Branch

Comment 3

13 years ago
Maybe related to bug 285556 comment 3 or Firefox bug 301802 (also Linux x86_64)?
(Reporter)

Comment 4

13 years ago
Become another ditails serial no error
maybe it'll be helpfull

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadShmSeg (invalid shared segment parameter)'.
  (Details: serial 106 error_code 168 request_code 148 minor_code 2)
*** Bug 317484 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
*** Bug 317494 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
*** Bug 317488 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
Yo I can confirm this (although I can't change the bug's state ;-) ),

I get the same error. It's too strange; While both, my desktop and my Thinkpad run Gentoo, I do only get this error on my desktop. Abviously it's got to do with some  packages on the desktop which are more up to date. Any ideas which could be relevant?

It's a real showstopper as there are a great number pages where Firefox does now (repeatably) crashes. 

Comment 9

13 years ago
We seem to be getting somewhere: I rebuilt Firefox with the DEBUG use flag. Just before it crashes I get this error log:

------8<----SNIP------->8--

For application/x-shockwave-flash found plugin /opt/netscape/plugins/libflashplayer.so
LoadPlugin() /opt/netscape/plugins/libflashplayer.so returned 8d872e8
nsPluginNativeWindowGtk2: NPPVpluginNeedsXEmbed=0
nsPluginNativeWindowGtk2: call SetWindow with xid=0x2a0214c
About to create new ws_info...
About to create new xtbin of 1 X 1 from 0x902da18...
About to show xtbin(0x90077d8)...
completed gtk_widget_show(0x90077d8)
nsPluginNativeWindowGtk2: NPPVpluginNeedsXEmbed=0
nsPluginNativeWindowGtk2: call SetWindow with xid=0x2a0214c
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 89 error_code 8 request_code 146 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
nsStringStats
 => mAllocCount:          45347
 => mReallocCount:        10528
 => mFreeCount:           34160  --  LEAKED 11187 !!!
 => mShareCount:          51293
 => mAdoptCount:           5009
 => mAdoptFreeCount:       4789  --  LEAKED 220 !!!
firefox-bin exited with non-zero status (1)

------8<----SNIP------->8--

Reading this I unmerged the flash plugin and retried wolemails.net and (ta ta taaaa): it works.

Comment 10

13 years ago
And before I forget: This is repeatable. When I remerge the flash plugin ("emerge net-www/netscape-flash") it will crash again 8-(
Are you using a 16bit display? I've heard reports that Flash doesn't work in 16-bit mode with some Xorg servers.

Comment 12

13 years ago
Yeah, I'm using the 16-bit mode. 
Hmm, how did you come to know that?
Thanks!
Try 24-bit mode and see if that makes the problem go away
Actually, see
https://bugzilla.novell.com/show_bug.cgi?id=135973#c11
Try setting environment variable XLIB_SKIP_ARGB_VISUALS=1 and see if *that* makes the bug go away.

Comment 15

13 years ago
Hi, sorry for the late reply. I've checked both solutions and both work. Running in 24-bit mode fixes it as well as still running a 16-bit mode and setting XLIB_SKIP_ARGB_VISUALS. 

Many thanks!
-Andreas

Updated

13 years ago
Summary: firefox crash - BadShmSeg → firefox crash - flash (16bit xserver) - BadShmSeg
Michelle, please see
https://bugzilla.novell.com/show_bug.cgi?id=135973#c11
We can work around this with a wrapper script but that's only a temporary solution because we will want to use these ARGB visuals soon.

Comment 17

12 years ago

*** This bug has been marked as a duplicate of 304370 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Duplicate of this bug: 317315
You need to log in before you can comment on or make changes to this bug.