Closed Bug 317255 Opened 19 years ago Closed 19 years ago

URLs with commas cannot be interpreted (-remote openurl)

Categories

(Core Graveyard :: X-remote, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 298960

People

(Reporter: wolfiR, Assigned: benjamin)

Details

This one is toolkit only (but I found no fitting component in product toolkit).
(It works correct in seamonkey)

firefox -remote
'openURL(http://www.spiegel.de/sport/fussball/0,1518,385708,00.html,new-tab)'

firefox will try to open "http://www.spiegel.de/sport/fussball/0" - removing
everything after the comma.

This is most probably caused by 
http://lxr.mozilla.org/mozilla1.8/source/browser/components/nsBrowserContentHandler.js#250

var remoteParams = a[2].split(",");

It's not possible to simply split at a comma as this is a common valid character for URLs.
I think this is pretty critical as this open-mechanism is used on Linux from many applications.

*** This bug has been marked as a duplicate of 298960 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.