Closed Bug 317268 Opened 15 years ago Closed 15 years ago

Impossible to copy/paste of css counter

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 12460

People

(Reporter: paul.pichaureau, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8) Gecko/20051107 Firefox/1.5

The css counter are displayed correctly in firefox 1.5RC3, but when I try to copy/paste a text where they appear, the numbers are not copied.

This is probably a bug, since the counter displayed with an ordered list (<ol></ol>) are correctly copied.

This is a minimal example.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>css embedded example</title>
<style type="text/css">
<!--
body { counter-reset: chapter; }

h1:before {
  content: counter(chapter) ".";
  counter-increment: chapter;
}
-->
</style>
</head>

<body>
<h1>Header one</h1>
<h1>Header two</h1>
<ol> <li> List one </li>
<li> list two </li>
</ol>
</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Display the minimal example above with firefox.
2. Try to copy the text in notepad.


Actual Results:  
The numbers before "Header one" and "HEader two" are not copied, but the numbers before "list one" and "list two" are.

Expected Results:  
All the numbers should be copied.

*** This bug has been marked as a duplicate of 12460 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.