Firefox crashes when trying to play audio via /dev/dsp if hardware has no sound support

RESOLVED DUPLICATE of bug 317209

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 317209
12 years ago
11 years ago

People

(Reporter: Antonio M. D'souza, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051010 Firefox/1.0.7 (Ubuntu package 1.0.7)

Firefox crashes with the following console mesage when attempting to load up the Tibco home page (which contains Flash content) because it tries to produce audio but my machine has no sound hardware in it:

NP_Initialize
New
open dsp: No such file or directory
SetWindow
Destroy
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadShmSeg (invalid shared segment parameter)'.
  (Details: serial 31 error_code 153 request_code 142 minor_code 2)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Running with the --sync option prevents the crash but displays a message about "fscommand" not being a supported protocol...

FYI: there is o crash in Epiphany.

Reproducible: Always

Steps to Reproduce:
On a machine with no sound hardware, open http://tibco.com/ in Firefox.
Actual Results:  
Firefox crashes.

Expected Results:  
The page should load up.

Comment 1

12 years ago
it's simillary 317209

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 317209
You need to log in before you can comment on or make changes to this bug.