code to play with treechildren only works if it can't find treechildren

VERIFIED DUPLICATE of bug 221995

Status

Other Applications
DOM Inspector
--
major
VERIFIED DUPLICATE of bug 221995
12 years ago
11 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 obsolete attachment)

(Reporter)

Description

12 years ago
Error ``aTreeChildren.appendChild is not a function'' [xs] in file ``chrome://inspector/content/viewers/jsObject/jsObject.js'', line 244, character 0.
Stopped for error handler.
#0: function anonymous(aTreeChildren=HTMLCollection:{0}, aName=string:"nodeName", aValue=string:"#text", aObject=Text:{1}) in <chrome://inspector/content/viewers/jsObject/jsObject.js> line 244
242: tr.appendChild(tc);
243:
244: aTreeChildren.appendChild(ti);
245:
246: // listen for changes to open attribute

#0: function anonymous(aTreeChildren=HTMLCollection:{0}, aName=string:"nodeName", aValue=string:"#text", aObject=Text:{1}) in <chrome://inspector/content/viewers/jsObject/jsObject.js> line 244
#1: function anonymous(aTreeChildren=HTMLCollection:{0}, aObject=Text:{1}) in <chrome://inspector/content/viewers/jsObject/jsObject.js> line 197
#2: function anonymous(aItem=XULElement:{2}) in <chrome://inspector/content/viewers/jsObject/jsObject.js> line 260
#3: function onTreeItemAttrModified(aEvent=MutationEvent:{0}) in <chrome://inspector/content/viewers/jsObject/jsObject.js> line 272
#4: toggleOpenState x-jsd:native-code
#5: function changeOpenState(row=integer:0, openState=void:void) in <chrome://global/content/bindings/tree.xml> line 216
#6: function onxblclick(event=MouseEvent:{0}) in <chrome://global/content/bindings/tree.xml> line 642

0001: aTreeChildren
$[0] = [HTMLCollection] [class: HTMLCollection] {0}
(Reporter)

Comment 1

12 years ago
Created attachment 203923 [details] [diff] [review]
get treechildren from nodelist
Attachment #203923 - Flags: review?(neil.parkwaycc.co.uk)

Comment 2

12 years ago
For some reason I already have the following patch applied to my tree:


*** This bug has been marked as a duplicate of 221995 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 3

12 years ago
Comment on attachment 203923 [details] [diff] [review]
get treechildren from nodelist

See https://bugzilla.mozilla.org/attachment.cgi?id=203931&action=edit
Attachment #203923 - Attachment is obsolete: true
Attachment #203923 - Flags: review?(neil.parkwaycc.co.uk)
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
Assignee: dom-inspector → nobody
QA Contact: timeless → dom-inspector
You need to log in before you can comment on or make changes to this bug.