Extension install problems

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: kelvSYC, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

If an extension fails to install by clicking on a .xpi link (either because of download error or the site being blocked, for example), clicking on the same .xpi link will do nothing.  Nor will it do anything if you reload the page, or move to a different page and come back to it.  (If the site is blocked, unblocking and trying again doesn't help either).

Reproducible: Always

Steps to Reproduce:
1. Locate a .xpi link, making sure that it's not on the list of allowed sites for .xpi extensions
2. Click on it, and it should fail
3. Add link to list, and try again

Actual Results:  
Nothing happens

Expected Results:  
The install dialog should pop up
This is WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051121 Firefox/1.5 ID:2005112104

I know you state this happens with all installs but would you provide a link to one this happens with?
Are there any errors in the JavaScript console?
Does this happen with a new profile?
(Reporter)

Comment 2

13 years ago
It happens only on the Mac - Linux and Windows 1.07 and 1.5b work fine.  There is nothing in the Javascript console.  It can be reproduced on either a stock build or a customized one.

Comment 3

13 years ago
I am experiencing this exact same behavior on WinXP using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5, as downloaded today. This was an upgrade install from a fully-patched 1.0 installation.

The first several extensions I tried were on a site that was not on the allowed sites list (releases.mozilla.org).  I got the message "software installation is currently disabled. Click Edit Options and try again."  In "Edit Options" there is no longer an "Allow sites to install software" checkbox, but I added releases.mozilla.org to the list of allowed sites.  I even tried removing the "Warn" checkmark altogether, and restarted Firefox.  Still won't allow any installation of extensions from releases.mozilla.org.

Need to update to ALL on OS and platforms...
Karen - I believe that what you describe is different and is bug 310737.

Reporter - I haven't had a chance to verify this on a Mac OS X system yet... could you verify that you are experiencing bug 310737?

Comment 5

13 years ago
Robert,

You are correct regarding my bug.  It is bug 310737 and there is a workaround for it for now.  I hadn't found it on this forum when I searched.  Thank you!
Reporter, can you respond to the questions in comment #1?
Unable to reproduce and no response from the reporter to the request for additional information. Resolving -> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.